summaryrefslogtreecommitdiffstats
path: root/unix/configure.in
diff options
context:
space:
mode:
authordkf <donal.k.fellows@manchester.ac.uk>2008-12-14 13:32:11 (GMT)
committerdkf <donal.k.fellows@manchester.ac.uk>2008-12-14 13:32:11 (GMT)
commit9b6fa1e54afb4f824ac6366f8e89439a3ec3be8e (patch)
treec82eb186ea5557b9639b822eadb8e951de54aa1e /unix/configure.in
parenta2110892447b53f535fd7d7aba9786904a82abf8 (diff)
downloadtcl-9b6fa1e54afb4f824ac6366f8e89439a3ec3be8e.zip
tcl-9b6fa1e54afb4f824ac6366f8e89439a3ec3be8e.tar.gz
tcl-9b6fa1e54afb4f824ac6366f8e89439a3ec3be8e.tar.bz2
Improve build rules on Win w.r.t. zlib
Improve autoconf magic on Unix and Win
Diffstat (limited to 'unix/configure.in')
-rw-r--r--unix/configure.in20
1 files changed, 10 insertions, 10 deletions
diff --git a/unix/configure.in b/unix/configure.in
index 5f6d0c9..3b73135 100644
--- a/unix/configure.in
+++ b/unix/configure.in
@@ -3,7 +3,7 @@ dnl This file is an input file used by the GNU "autoconf" program to
dnl generate the file "configure", which is run during Tcl installation
dnl to configure the system for the local environment.
#
-# RCS: @(#) $Id: configure.in,v 1.194 2008/12/12 16:22:57 dkf Exp $
+# RCS: @(#) $Id: configure.in,v 1.195 2008/12/14 13:32:11 dkf Exp $
AC_INIT([tcl],[8.6])
AC_PREREQ(2.59)
@@ -117,22 +117,22 @@ SC_ENABLE_SHARED
# Add stuff for zlib
#------------------------------------------------------------------------
-zlib_ok=yes
+tcl_ok=yes
AC_CHECK_HEADER([zlib.h],[
AC_CHECK_TYPE([gz_header],[],[
- zlib_ok=no
+ tcl_ok=no
AC_MSG_WARN([todo: Add -Icompat/zlib/include to compile lines])
],[#include <zlib.h>])],[
- zlib_ok=no
+ tcl_ok=no
AC_MSG_WARN([todo: Add -Icompat/zlib/include to compile lines])
])
-AC_SEARCH_LIBS([deflateSetHeader],[z],[],[
- zlib_ok=no
+AS_IF([test $tcl_ok = yes], [
+ AC_SEARCH_LIBS([deflateSetHeader],[z],[],[
+ tcl_ok=no
AC_MSG_WARN([todo: Add compat/zlib to list of things to build])
-])
-if test $zlib_ok = yes; then
- AC_DEFINE(HAVE_ZLIB, 1, [Is there an installed zlib?])
-fi
+ ])])
+AS_IF([test $tcl_ok = yes], [
+ AC_DEFINE(HAVE_ZLIB, 1, [Is there an installed zlib?])])
#--------------------------------------------------------------------
# The statements below define a collection of compile flags. This