summaryrefslogtreecommitdiffstats
path: root/unix/configure.in
diff options
context:
space:
mode:
authorhobbs <hobbs>2004-05-26 22:51:53 (GMT)
committerhobbs <hobbs>2004-05-26 22:51:53 (GMT)
commit4761295d5dc11e76a759fc26de4b30d09bccd1a5 (patch)
treec10f5e706aedf192e66a2c06265018f7f5cc8e21 /unix/configure.in
parent6cc01e6368eeff74fcaff85e89e3910e120e7afc (diff)
downloadtcl-4761295d5dc11e76a759fc26de4b30d09bccd1a5.zip
tcl-4761295d5dc11e76a759fc26de4b30d09bccd1a5.tar.gz
tcl-4761295d5dc11e76a759fc26de4b30d09bccd1a5.tar.bz2
* unix/Makefile.in: Rework configure ordering to TCL_LINK_LIBS,
* unix/tcl.m4: ENABLE_SHARED, CONFIG_CFLAGS, & ENABLE_SYMBOLS * unix/configure: before TCL_EARLY_FLAGS and TCL_64BIT_FLAGS * unix/configure.in: (about 400 lines earlier) in configure.in. This forces CFLAGS configuration to be done before many tests, which is needed for 64-bit builds and may affect other builds. Also make CONFIG_CFLAGS append to CFLAGS directly instead of using EXTRA_CFLAGS, and have LDFLAGS append to any existing value. [Bug #874058] * unix/dltest/Makefile.in: change EXTRA_CFLAGS to DEFS
Diffstat (limited to 'unix/configure.in')
-rw-r--r--unix/configure.in50
1 files changed, 25 insertions, 25 deletions
diff --git a/unix/configure.in b/unix/configure.in
index 34d5019..9e3f44c 100644
--- a/unix/configure.in
+++ b/unix/configure.in
@@ -3,7 +3,7 @@ dnl This file is an input file used by the GNU "autoconf" program to
dnl generate the file "configure", which is run during Tcl installation
dnl to configure the system for the local environment.
#
-# RCS: @(#) $Id: configure.in,v 1.112 2004/03/26 19:47:29 dgp Exp $
+# RCS: @(#) $Id: configure.in,v 1.113 2004/05/26 22:51:58 hobbs Exp $
AC_INIT(../generic/tcl.h)
AC_PREREQ(2.57)
@@ -76,6 +76,30 @@ fi
fi
#--------------------------------------------------------------------
+# Look for libraries that we will need when compiling the Tcl shell
+#--------------------------------------------------------------------
+
+SC_TCL_LINK_LIBS
+
+# Add the threads support libraries
+
+LIBS="$LIBS$THREADS_LIBS"
+
+SC_ENABLE_SHARED
+
+#--------------------------------------------------------------------
+# The statements below define a collection of compile flags. This
+# macro depends on the value of SHARED_BUILD, and should be called
+# after SC_ENABLE_SHARED checks the configure switches.
+#--------------------------------------------------------------------
+
+SC_CONFIG_CFLAGS
+
+SC_ENABLE_SYMBOLS
+
+TCL_DBGX=${DBGX}
+
+#--------------------------------------------------------------------
# Detect what compiler flags to set for 64-bit support.
#--------------------------------------------------------------------
@@ -435,30 +459,6 @@ AC_CHECK_FUNCS(chflags)
AC_CHECK_FUNCS(getattrlist)
#--------------------------------------------------------------------
-# Look for libraries that we will need when compiling the Tcl shell
-#--------------------------------------------------------------------
-
-SC_TCL_LINK_LIBS
-
-# Add the threads support libraries
-
-LIBS="$LIBS$THREADS_LIBS"
-
-SC_ENABLE_SHARED
-
-#--------------------------------------------------------------------
-# The statements below define a collection of compile flags. This
-# macro depends on the value of SHARED_BUILD, and should be called
-# after SC_ENABLE_SHARED checks the configure switches.
-#--------------------------------------------------------------------
-
-SC_CONFIG_CFLAGS
-
-SC_ENABLE_SYMBOLS
-
-TCL_DBGX=${DBGX}
-
-#--------------------------------------------------------------------
# The statements below check for systems where POSIX-style
# non-blocking I/O (O_NONBLOCK) doesn't work or is unimplemented.
# On these systems (mostly older ones), use the old BSD-style