summaryrefslogtreecommitdiffstats
path: root/unix/configure.in
diff options
context:
space:
mode:
authorandreas_kupries <akupries@shaw.ca>2006-09-12 22:51:32 (GMT)
committerandreas_kupries <akupries@shaw.ca>2006-09-12 22:51:32 (GMT)
commitc5e2ae09424655cfb0a69b301ee78dcda43b63f4 (patch)
tree35d3635d12676b3d11fccc2db6014dcdeb49d22b /unix/configure.in
parent0d1733cd6115eb7c1cb427a936de39f20ead4f23 (diff)
downloadtcl-c5e2ae09424655cfb0a69b301ee78dcda43b63f4.zip
tcl-c5e2ae09424655cfb0a69b301ee78dcda43b63f4.tar.gz
tcl-c5e2ae09424655cfb0a69b301ee78dcda43b63f4.tar.bz2
* unix/configure.in (HAVE_MTSAFE_GETHOST*): Modified to recognize
HP-UX 11.00 and beyond as having mt-safe implementations of the gethost functions. * unix/configure: Regenerated, using autoconf 2.59
Diffstat (limited to 'unix/configure.in')
-rw-r--r--unix/configure.in13
1 files changed, 12 insertions, 1 deletions
diff --git a/unix/configure.in b/unix/configure.in
index 1abf209..24f90a7 100644
--- a/unix/configure.in
+++ b/unix/configure.in
@@ -3,7 +3,7 @@ dnl This file is an input file used by the GNU "autoconf" program to
dnl generate the file "configure", which is run during Tcl installation
dnl to configure the system for the local environment.
#
-# RCS: @(#) $Id: configure.in,v 1.147 2006/09/10 17:04:07 das Exp $
+# RCS: @(#) $Id: configure.in,v 1.148 2006/09/12 22:51:33 andreas_kupries Exp $
AC_INIT([tcl],[8.5])
AC_PREREQ(2.59)
@@ -180,6 +180,17 @@ if test "${TCL_THREADS}" = 1; then
[Do we have MT-safe gethostbyname() ?])
AC_DEFINE(HAVE_MTSAFE_GETHOSTBYADDR, 1,
[Do we have MT-safe gethostbyaddr() ?])
+
+ elif test "`uname -s`" = "HP-UX" && \
+ test "`uname -r|sed -e 's|B\.||' -e 's|\..*$||'`" -gt 10; then
+ # Starting with HPUX 11.00 (we believe), gethostbyX
+ # are actually MT-safe as they always return pointers
+ # from TSD instead of static storage.
+ AC_DEFINE(HAVE_MTSAFE_GETHOSTBYNAME, 1,
+ [Do we have MT-safe gethostbyname() ?])
+ AC_DEFINE(HAVE_MTSAFE_GETHOSTBYADDR, 1,
+ [Do we have MT-safe gethostbyaddr() ?])
+
else
SC_TCL_GETHOSTBYNAME_R
SC_TCL_GETHOSTBYADDR_R