summaryrefslogtreecommitdiffstats
path: root/unix/configure.in
diff options
context:
space:
mode:
authorstanton <stanton>1999-06-02 02:03:25 (GMT)
committerstanton <stanton>1999-06-02 02:03:25 (GMT)
commit508a5a579db79b4611b7c7fbbb417aed2319708b (patch)
treec5670d8764d8ace76ecd506599328a71165d94a1 /unix/configure.in
parent21c3baed52eba908b3e56f33f9d0f9541495616e (diff)
downloadtcl-508a5a579db79b4611b7c7fbbb417aed2319708b.zip
tcl-508a5a579db79b4611b7c7fbbb417aed2319708b.tar.gz
tcl-508a5a579db79b4611b7c7fbbb417aed2319708b.tar.bz2
* unix/configure.in: Fixed various small configure.in patches
submitted by Jan Nijtmans. [Bug: 2121]
Diffstat (limited to 'unix/configure.in')
-rw-r--r--unix/configure.in9
1 files changed, 5 insertions, 4 deletions
diff --git a/unix/configure.in b/unix/configure.in
index 285004d..ec961ae 100644
--- a/unix/configure.in
+++ b/unix/configure.in
@@ -2,7 +2,7 @@ dnl This file is an input file used by the GNU "autoconf" program to
dnl generate the file "configure", which is run during Tcl installation
dnl to configure the system for the local environment.
AC_INIT(../generic/tcl.h)
-# RCS: @(#) $Id: configure.in,v 1.37 1999/05/26 02:39:13 stanton Exp $
+# RCS: @(#) $Id: configure.in,v 1.38 1999/06/02 02:03:25 stanton Exp $
TCL_VERSION=8.1
TCL_MAJOR_VERSION=8
@@ -774,7 +774,8 @@ case $system in
SHLIB_LD="$fullSrcDir/ldAix /bin/ld -bhalt:4 -bM:SRE -bE:lib.exp -H512 -T512"
SHLIB_LD_LIBS='${LIBS}'
SHLIB_SUFFIX=".so"
- DL_OBJS="tclLoadDl.o tclLoadAix.o"
+ DL_OBJS="tclLoadDl.o
+ LIBOBJS="$LIBOBJS tclLoadAix.o"
DL_LIBS="-lld"
LD_FLAGS=""
LD_SEARCH_FLAGS='-L${LIB_RUNTIME_DIR}'
@@ -871,7 +872,7 @@ case $system in
;;
Linux*)
SHLIB_CFLAGS="-fPIC"
- SHLIB_LD_LIBS="${LIBS}"
+ SHLIB_LD_LIBS='${LIBS}'
SHLIB_SUFFIX=".so"
if test "$have_dl" = yes; then
SHLIB_LD="${CC} -shared"
@@ -908,7 +909,7 @@ case $system in
LD_FLAGS="-Wl,-Bexport"
LD_SEARCH_FLAGS=""
;;
- NetBSD-*|FreeBSD-[12].*|OpenBSD-*)
+ NetBSD-*|FreeBSD-[[12]].*|OpenBSD-*)
# Not available on all versions: check for include file.
AC_CHECK_HEADER(dlfcn.h, [
SHLIB_CFLAGS="-fpic"