summaryrefslogtreecommitdiffstats
path: root/unix/configure.in
diff options
context:
space:
mode:
authorescoffon <escoffon>1998-07-22 13:39:13 (GMT)
committerescoffon <escoffon>1998-07-22 13:39:13 (GMT)
commit693bcba7c5261324ef8560a98f6d7b08f033bed7 (patch)
treeca9a57d398526ceccce37f75c32e985171594eb3 /unix/configure.in
parentb9b329dc1932857d938bd6e835ce5ad528d62923 (diff)
downloadtcl-693bcba7c5261324ef8560a98f6d7b08f033bed7.zip
tcl-693bcba7c5261324ef8560a98f6d7b08f033bed7.tar.gz
tcl-693bcba7c5261324ef8560a98f6d7b08f033bed7.tar.bz2
Added support for specifying warning flags for the compiler, with checks
for gcc and appropriate defaults.
Diffstat (limited to 'unix/configure.in')
-rw-r--r--unix/configure.in10
1 files changed, 9 insertions, 1 deletions
diff --git a/unix/configure.in b/unix/configure.in
index fd88976..15c91d7 100644
--- a/unix/configure.in
+++ b/unix/configure.in
@@ -2,7 +2,7 @@ dnl This file is an input file used by the GNU "autoconf" program to
dnl generate the file "configure", which is run during Tcl installation
dnl to configure the system for the local environment.
AC_INIT(../generic/tcl.h)
-# SCCS: %Z% $Id: configure.in,v 1.8 1998/07/21 15:26:05 escoffon Exp $
+# SCCS: %Z% $Id: configure.in,v 1.9 1998/07/22 13:39:13 escoffon Exp $
TCL_VERSION=8.0
TCL_MAJOR_VERSION=8
@@ -29,6 +29,13 @@ AC_SUBST(CC)
fi
AC_C_CROSS
+# set the warning flags depending on whether or not we are using gcc
+if test "${GCC}" = "yes" ; then
+ CFLAGS_WARNING="-Wall -Wconversion"
+else
+ CFLAGS_WARNING=""
+fi
+
#--------------------------------------------------------------------
# Supply substitutes for missing POSIX library procedures, or
# set flags so Tcl uses alternate procedures.
@@ -1227,6 +1234,7 @@ AC_SUBST(BUILD_DLTEST)
AC_SUBST(CFLAGS_DEBUG)
AC_SUBST(CFLAGS_DEFAULT)
AC_SUBST(CFLAGS_OPTIMIZE)
+AC_SUBST(CFLAGS_WARNING)
AC_SUBST(CFG_TCL_SHARED_LIB_SUFFIX)
AC_SUBST(CFG_TCL_UNSHARED_LIB_SUFFIX)
AC_SUBST(DBGX)