summaryrefslogtreecommitdiffstats
path: root/unix/configure.in
diff options
context:
space:
mode:
authordgp <dgp@users.sourceforge.net>2012-06-08 13:14:19 (GMT)
committerdgp <dgp@users.sourceforge.net>2012-06-08 13:14:19 (GMT)
commit7e302d3ca75cd9eb6998e895cf344665b1d08e5e (patch)
treea5906f025d3dabfe0ae754285014064899728fc1 /unix/configure.in
parent58d31239da28572a5de112c0792a6e071066fddc (diff)
parent9ea2ab76f4646c44e090b45ba151a94d38b085f1 (diff)
downloadtcl-7e302d3ca75cd9eb6998e895cf344665b1d08e5e.zip
tcl-7e302d3ca75cd9eb6998e895cf344665b1d08e5e.tar.gz
tcl-7e302d3ca75cd9eb6998e895cf344665b1d08e5e.tar.bz2
Update autogoo for gettimeofday(). Thanks Joe English.
Diffstat (limited to 'unix/configure.in')
-rw-r--r--unix/configure.in9
1 files changed, 3 insertions, 6 deletions
diff --git a/unix/configure.in b/unix/configure.in
index 441c98f..5f0fe0b 100644
--- a/unix/configure.in
+++ b/unix/configure.in
@@ -415,16 +415,13 @@ fi
# The code below deals with several issues related to gettimeofday:
# 1. Some systems don't provide a gettimeofday function at all
# (set NO_GETTOD if this is the case).
-# 2. SGI systems don't use the BSD form of the gettimeofday function,
-# but they have a BSDgettimeofday function that can be used instead.
-# 3. See if gettimeofday is declared in the <sys/time.h> header file.
+# 2. See if gettimeofday is declared in the <sys/time.h> header file.
# if not, set the GETTOD_NOT_DECLARED flag so that tclPort.h can
# declare it.
#--------------------------------------------------------------------
-AC_CHECK_FUNC(BSDgettimeofday,
- [AC_DEFINE(HAVE_BSDGETTIMEOFDAY, 1, [Do we have BSDgettimeofday()?])], [
- AC_CHECK_FUNC(gettimeofday, , [AC_DEFINE(NO_GETTOD, 1, [Do we have gettimeofday()?])])
+AC_CHECK_FUNC(gettimeofday,[],[
+ AC_DEFINE(NO_GETTOD, 1, [Do we have gettimeofday()?])
])
AC_CACHE_CHECK([for gettimeofday declaration], tcl_cv_grep_gettimeofday, [
AC_EGREP_HEADER(gettimeofday, sys/time.h,