summaryrefslogtreecommitdiffstats
path: root/unix/tcl.spec
diff options
context:
space:
mode:
authorericm <ericm>2000-02-14 22:40:56 (GMT)
committerericm <ericm>2000-02-14 22:40:56 (GMT)
commite411cd157324b6c27b10548c0b50704a7cbf4b37 (patch)
tree81d84e41bc97eb4e2c73afbb6d6179f0ed9d426c /unix/tcl.spec
parent7a903ce32d04f0ad3f058010246c045baf889802 (diff)
downloadtcl-e411cd157324b6c27b10548c0b50704a7cbf4b37.zip
tcl-e411cd157324b6c27b10548c0b50704a7cbf4b37.tar.gz
tcl-e411cd157324b6c27b10548c0b50704a7cbf4b37.tar.bz2
* unix/Makefile.in: Added rpm target to generate Tcl binary RPM.
* unix/tcl.spec: RPM specification file for a Tcl binary RPM for Linux.
Diffstat (limited to 'unix/tcl.spec')
-rw-r--r--unix/tcl.spec51
1 files changed, 51 insertions, 0 deletions
diff --git a/unix/tcl.spec b/unix/tcl.spec
new file mode 100644
index 0000000..b205733
--- /dev/null
+++ b/unix/tcl.spec
@@ -0,0 +1,51 @@
+# $Id: tcl.spec,v 1.1 2000/02/14 22:40:56 ericm Exp $
+# This file is the basis for a binary Tcl RPM for Linux.
+
+%define version 8.3.0
+%define directory /usr/local
+
+Summary: Tcl scripting language development environment
+Name: tcl
+Version: %{version}
+Release: 1
+Copyright: BSD
+Group: Development/Languages
+Source: ftp://ftp.scriptics.com/pub/tcl/tcl8_3/tcl%{version}.tar.gz
+URL: http://www.scriptics.com/
+Packager: Scriptics Corporation
+Buildroot: /var/tmp/%{name}%{version}
+
+%description
+The Tcl (Tool Command Language) provides a powerful platform for
+creating integration applications that tie together diverse
+applications, protocols, devices, and frameworks. When paired with
+the Tk toolkit, Tcl provides the fastest and most powerful way to
+create GUI applications that run on PCs, Unix, and the Macintosh. Tcl
+can also be used for a variety of web-related tasks and for creating
+powerful command languages for applications.
+
+%prep
+
+%build
+./configure --prefix %{directory} --exec-prefix %{directory}
+make CFLAGS=$RPM_OPT_FLAGS
+
+%install
+rm -rf $RPM_BUILD_ROOT
+make INSTALL_ROOT=$RPM_BUILD_ROOT install
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+# to create the tcl files list, comment out tk in the install section above,
+# then run "rpm -bi" then do a find from the build root directory,
+# and remove the files in specific directories which suffice by themselves,
+# then to create the files list for tk, uncomment tk, comment out tcl,
+# then rm -rf $RPM_BUILD_ROOT then rpm --short-circuit -bi then redo a find,
+# and remove the files in specific directories which suffice by themselves.
+%files -n tcl
+%defattr(-,root,root)
+%{directory}/lib
+%{directory}/bin
+%{directory}/include
+%{directory}/man