summaryrefslogtreecommitdiffstats
path: root/win/configure.in
diff options
context:
space:
mode:
authorKevin B Kenny <kennykb@acm.org>2008-12-20 21:40:27 (GMT)
committerKevin B Kenny <kennykb@acm.org>2008-12-20 21:40:27 (GMT)
commit6a64cdf71b3aa52680959e56d4d2c5fda3588f38 (patch)
treefd0aaa89dac6861a15d29bc456cfc43d31044094 /win/configure.in
parentd02b97bef3315cfb2bb8350d63a6bbca58fc6134 (diff)
downloadtcl-6a64cdf71b3aa52680959e56d4d2c5fda3588f38.zip
tcl-6a64cdf71b3aa52680959e56d4d2c5fda3588f38.tar.gz
tcl-6a64cdf71b3aa52680959e56d4d2c5fda3588f38.tar.bz2
* win/Makefile.in:
* win/configure.in: Renamed the static library libtcl86s.a to have a name distinct from the import library libtcl86.a. This renaming dodges an ancient bug in the Makefile revealed by the last commit where the $(TCL_LIB_FILE) rule can fire to try to build the static library in a --enable-shared build (and create a static library that subsequently fails to link). *** POTENTIAL INCOMPATIBILITY *** for embedders who link to the static library, but I couldn't figure out how to sort this out any other way. * win/configure: Autoconf 2.59
Diffstat (limited to 'win/configure.in')
-rw-r--r--win/configure.in29
1 files changed, 22 insertions, 7 deletions
diff --git a/win/configure.in b/win/configure.in
index 8b24999..8b8e61d 100644
--- a/win/configure.in
+++ b/win/configure.in
@@ -3,7 +3,7 @@
# generate the file "configure", which is run during Tcl installation
# to configure the system for the local environment.
#
-# RCS: @(#) $Id: configure.in,v 1.114 2008/12/19 03:54:44 dgp Exp $
+# RCS: @(#) $Id: configure.in,v 1.115 2008/12/20 21:40:27 kennykb Exp $
AC_INIT(../generic/tcl.h)
AC_PREREQ(2.59)
@@ -381,12 +381,6 @@ eval "TCL_SRC_DIR=\"`cd $srcdir/..; pwd`\""
eval "TCL_DLL_FILE=tcl${VER}${DLLSUFFIX}"
-eval "TCL_LIB_FILE=${LIBPREFIX}tcl$VER${LIBSUFFIX}"
-
-eval "TCL_LIB_FLAG=\"-ltcl${VER}${LIBFLAGSUFFIX}\""
-eval "TCL_BUILD_LIB_SPEC=\"-L`pwd` ${TCL_LIB_FLAG}\""
-eval "TCL_LIB_SPEC=\"-L${libdir} ${TCL_LIB_FLAG}\""
-
eval "TCL_STUB_LIB_FILE=\"${LIBPREFIX}tclstub${VER}${LIBSUFFIX}\""
eval "TCL_STUB_LIB_FLAG=\"-ltclstub${VER}${LIBFLAGSUFFIX}\""
eval "TCL_BUILD_STUB_LIB_SPEC=\"-L`pwd` ${TCL_STUB_LIB_FLAG}\""
@@ -394,6 +388,23 @@ eval "TCL_STUB_LIB_SPEC=\"-L${libdir} ${TCL_STUB_LIB_FLAG}\""
eval "TCL_BUILD_STUB_LIB_PATH=\"`pwd`/${TCL_STUB_LIB_FILE}\""
eval "TCL_STUB_LIB_PATH=\"${libdir}/${TCL_STUB_LIB_FILE}\""
+eval "TCL_STATIC_LIB_FILE=\"${LIBPREFIX}tcl${VER}s${LIBSUFFIX}\""
+eval "TCL_STATIC_LIB_FLAG=\"-ltcl${VER}s${LIBFLAGSUFFIX}\""
+
+eval "TCL_IMPORT_LIB_FILE=\"${LIBPREFIX}tcl${VER}${LIBSUFFIX}\""
+eval "TCL_IMPORT_LIB_FLAG=\"-ltcl${VER}${LIBFLAGSUFFIX}\""
+
+if test ${SHARED_BUILD} = 0 ; then
+ eval "TCL_LIB_FILE=\"${TCL_STATIC_LIB_FILE}\""
+ eval "TCL_LIB_FLAG=\"${TCL_STATIC_LIB_FLAG}\""
+else
+ eval "TCL_LIB_FILE=\"${TCL_IMPORT_LIB_FILE}\""
+ eval "TCL_LIB_FLAG=\"${TCL_IMPORT_LIB_FLAG}\""
+fi
+eval "TCL_BUILD_LIB_SPEC=\"-L`pwd` ${TCL_LIB_FLAG}\""
+eval "TCL_LIB_SPEC=\"-L${libdir} ${TCL_LIB_FLAG}\""
+
+
# Install time header dir can be set via --includedir
eval "TCL_INCLUDE_SPEC=\"-I${includedir}\""
@@ -447,6 +458,10 @@ AC_SUBST(PKG_CFG_ARGS)
AC_SUBST(TCL_LIB_FILE)
AC_SUBST(TCL_LIB_FLAG)
+AC_SUBST(TCL_STATIC_LIB_FILE)
+AC_SUBST(TCL_STATIC_LIB_FLAG)
+AC_SUBST(TCL_IMPORT_LIB_FILE)
+AC_SUBST(TCL_IMPORT_LIB_FLAG)
# empty on win
AC_SUBST(TCL_LIB_SPEC)
AC_SUBST(TCL_STUB_LIB_FILE)