summaryrefslogtreecommitdiffstats
path: root/win/configure.in
diff options
context:
space:
mode:
authormdejong <mdejong@noemail.net>2003-01-13 01:27:49 (GMT)
committermdejong <mdejong@noemail.net>2003-01-13 01:27:49 (GMT)
commita18b64bbb93ce44769745eeed8e70102c82a7266 (patch)
tree4181938d9b16505f540d6023e6d4474966db168f /win/configure.in
parentbc7ac0c33c841f7e376d60e1a8553f898caa3629 (diff)
downloadtcl-a18b64bbb93ce44769745eeed8e70102c82a7266.zip
tcl-a18b64bbb93ce44769745eeed8e70102c82a7266.tar.gz
tcl-a18b64bbb93ce44769745eeed8e70102c82a7266.tar.bz2
* win/configure: Regen.
* win/configure.in: Check for typedefs like LPFN_ACCEPT in winsock2.h and define HAVE_NO_LPFN_DECLS if not found. * win/tclWinSock.c: Define LPFN_* typedefs if HAVE_NO_LPFN_DECLS is defined. This fixes the build under Mingw and Cygwin, it was broken by the changes made on 2002-11-26. FossilOrigin-Name: 4aad945b11965fa9a3f0659206147220c4746ba1
Diffstat (limited to 'win/configure.in')
-rw-r--r--win/configure.in25
1 files changed, 24 insertions, 1 deletions
diff --git a/win/configure.in b/win/configure.in
index d580a63..9dfaebe 100644
--- a/win/configure.in
+++ b/win/configure.in
@@ -3,7 +3,7 @@
# generate the file "configure", which is run during Tcl installation
# to configure the system for the local environment.
#
-# RCS: @(#) $Id: configure.in,v 1.60 2002/12/13 17:46:01 dgp Exp $
+# RCS: @(#) $Id: configure.in,v 1.61 2003/01/13 01:27:51 mdejong Exp $
AC_INIT(../generic/tcl.h)
AC_PREREQ(2.13)
@@ -146,6 +146,29 @@ if test "$tcl_cv_eh_disposition" = "no" ; then
[Defined when cygwin/mingw does not support EXCEPTION DISPOSITION])
fi
+
+# Check to see if the winsock2.h include file provided contains
+# typedefs like LPFN_ACCEPT and friends.
+#
+AC_CACHE_CHECK(for LPFN_ACCEPT support in winsock2.h,
+ tcl_cv_lpfn_decls,
+AC_TRY_COMPILE([
+#define WIN32_LEAN_AND_MEAN
+#include <windows.h>
+#undef WIN32_LEAN_AND_MEAN
+#include <winsock2.h>
+],
+[
+ LPFN_ACCEPT accept;
+],
+ tcl_cv_lpfn_decls=yes,
+ tcl_cv_lpfn_decls=no)
+)
+if test "$tcl_cv_lpfn_decls" = "no" ; then
+ AC_DEFINE(HAVE_NO_LPFN_DECLS, 1,
+ [Defined when cygwin/mingw does not support LPFN_ACCEPT and friends.])
+fi
+
#--------------------------------------------------------------------
# Determines the correct binary file extension (.o, .obj, .exe etc.)
#--------------------------------------------------------------------