summaryrefslogtreecommitdiffstats
path: root/win/configure.in
diff options
context:
space:
mode:
authormdejong <mdejong@noemail.net>2002-11-06 10:44:13 (GMT)
committermdejong <mdejong@noemail.net>2002-11-06 10:44:13 (GMT)
commitfdd7933bc7031a5752f663bb798bce3332d4444f (patch)
tree60a5ae6990a2dbdfd94a55070fc14c922d30255f /win/configure.in
parentf42893991f173894e9d697b825202e07cc8375bb (diff)
downloadtcl-fdd7933bc7031a5752f663bb798bce3332d4444f.zip
tcl-fdd7933bc7031a5752f663bb798bce3332d4444f.tar.gz
tcl-fdd7933bc7031a5752f663bb798bce3332d4444f.tar.bz2
* unix/configure: Regen.
* unix/tcl.m4 (SC_CONFIG_CFLAGS): Generate a fatal configure error if no ar program can be found on the path. [Bug #582039] * win/configure: Regen. * win/configure.in: Check that AR, RANLIB, and RC are found on the path when building with gcc. FossilOrigin-Name: 844cdd9ad45d0dd06d4236722676cef62916b062
Diffstat (limited to 'win/configure.in')
-rw-r--r--win/configure.in18
1 files changed, 14 insertions, 4 deletions
diff --git a/win/configure.in b/win/configure.in
index d684446..6a85d78 100644
--- a/win/configure.in
+++ b/win/configure.in
@@ -3,7 +3,7 @@
# generate the file "configure", which is run during Tcl installation
# to configure the system for the local environment.
#
-# RCS: @(#) $Id: configure.in,v 1.58 2002/10/22 18:56:28 hobbs Exp $
+# RCS: @(#) $Id: configure.in,v 1.59 2002/11/06 10:44:15 mdejong Exp $
AC_INIT(../generic/tcl.h)
AC_PREREQ(2.13)
@@ -57,14 +57,24 @@ AC_PROG_CC
# autoconf 2.50. You can also just set
# the CC, AR, RANLIB, and RC environment
# variables if you want to cross compile.
-dnl AC_CHECK_TOOL(AR, ar, :)
-dnl AC_CHECK_TOOL(RANLIB, ranlib, :)
-dnl AC_CHECK_TOOL(RC, windres, :)
+dnl AC_CHECK_TOOL(AR, ar)
+dnl AC_CHECK_TOOL(RANLIB, ranlib)
+dnl AC_CHECK_TOOL(RC, windres)
if test "${GCC}" = "yes" ; then
AC_CHECK_PROG(AR, ar, ar)
AC_CHECK_PROG(RANLIB, ranlib, ranlib)
AC_CHECK_PROG(RC, windres, windres)
+
+ if test "${AR}" = "" ; then
+ AC_MSG_ERROR([Required archive tool 'ar' not found on PATH.])
+ fi
+ if test "${RANLIB}" = "" ; then
+ AC_MSG_ERROR([Required archive index tool 'ranlib' not found on PATH.])
+ fi
+ if test "${RC}" = "" ; then
+ AC_MSG_ERROR([Required resource tool 'windres' not found on PATH.])
+ fi
fi
#--------------------------------------------------------------------