summaryrefslogtreecommitdiffstats
path: root/win/configure.in
diff options
context:
space:
mode:
authormdejong <mdejong>2003-01-24 08:04:25 (GMT)
committermdejong <mdejong>2003-01-24 08:04:25 (GMT)
commit709661acd4c4100385dc6779b3c10442599ae342 (patch)
tree2d9d1ae6937fa03c9a0e577aa1787aa117cfd304 /win/configure.in
parentffc4888f61c1b387a9b1263b73a538878e57a672 (diff)
downloadtcl-709661acd4c4100385dc6779b3c10442599ae342.zip
tcl-709661acd4c4100385dc6779b3c10442599ae342.tar.gz
tcl-709661acd4c4100385dc6779b3c10442599ae342.tar.bz2
* win/configure: Regen.
* win/configure.in: * win/tclWin32Dll.c (TclpCheckStackSpace): Rework the SEH exception handler logic to avoid using the stack since alloca will modify the stack. This was causing a nasty bug that would set the exception handler to 0 because it tried to pop the previous exception handler off the top of the stack.
Diffstat (limited to 'win/configure.in')
-rw-r--r--win/configure.in25
1 files changed, 24 insertions, 1 deletions
diff --git a/win/configure.in b/win/configure.in
index b641255..0b99959 100644
--- a/win/configure.in
+++ b/win/configure.in
@@ -3,7 +3,7 @@
# generate the file "configure", which is run during Tcl installation
# to configure the system for the local environment.
#
-# RCS: @(#) $Id: configure.in,v 1.62 2003/01/13 07:01:06 mdejong Exp $
+# RCS: @(#) $Id: configure.in,v 1.63 2003/01/24 08:04:28 mdejong Exp $
AC_INIT(../generic/tcl.h)
AC_PREREQ(2.13)
@@ -194,6 +194,29 @@ if test "$tcl_cv_winnt_ignore_void" = "yes" ; then
[Defined when cygwin/mingw ignores VOID define in winnt.h])
fi
+# Check to see if malloc.h is missing the alloca function
+# declaration. This is known to be a problem with Mingw.
+
+AC_CACHE_CHECK(for alloca declaration in malloc.h,
+ tcl_cv_malloc_decl_alloca,
+AC_TRY_COMPILE([
+#include <malloc.h>
+],
+[
+ size_t arg = 0;
+ void* ptr;
+ ptr = alloca;
+ ptr = alloca(arg);
+],
+ tcl_cv_malloc_decl_alloca=yes,
+ tcl_cv_malloc_decl_alloca=no)
+)
+if test "$tcl_cv_malloc_decl_alloca" = "no" ; then
+ AC_DEFINE(HAVE_NO_ALLOC_DECL, 1,
+ [Defined when alloca decl is missing from malloc.h])
+fi
+
+
#--------------------------------------------------------------------
# Determines the correct binary file extension (.o, .obj, .exe etc.)
#--------------------------------------------------------------------