summaryrefslogtreecommitdiffstats
path: root/win/configure.in
diff options
context:
space:
mode:
authornijtmans <nijtmans>2010-12-03 09:19:39 (GMT)
committernijtmans <nijtmans>2010-12-03 09:19:39 (GMT)
commitea3383df4de871af4befa8a8c0183d7f4b4d1cbd (patch)
tree84f06ceb25a53b5aff218927cade3aa04bcfc284 /win/configure.in
parent6c7ac341739cf01e0a6a385687b55339aa48e1eb (diff)
downloadtcl-ea3383df4de871af4befa8a8c0183d7f4b4d1cbd.zip
tcl-ea3383df4de871af4befa8a8c0183d7f4b4d1cbd.tar.gz
tcl-ea3383df4de871af4befa8a8c0183d7f4b4d1cbd.tar.bz2
silence gcc warning when using -Wwrite-strings
silence gcc warning for non-IEEE platforms [Patch #3116490] cross-compile Tcl mingw32 on unix. This makes it possible to cross-compile Tcl/Tk for Windows (either 32-bit or 64-bit) out-of-the-box on UNIX, using mingw-w64 build tools.
Diffstat (limited to 'win/configure.in')
-rw-r--r--win/configure.in13
1 files changed, 12 insertions, 1 deletions
diff --git a/win/configure.in b/win/configure.in
index f36962c..f5cdebb 100644
--- a/win/configure.in
+++ b/win/configure.in
@@ -3,7 +3,7 @@
# generate the file "configure", which is run during Tcl installation
# to configure the system for the local environment.
#
-# RCS: @(#) $Id: configure.in,v 1.125 2010/11/18 23:15:18 nijtmans Exp $
+# RCS: @(#) $Id: configure.in,v 1.126 2010/12/03 09:19:39 nijtmans Exp $
AC_INIT(../generic/tcl.h)
AC_PREREQ(2.59)
@@ -306,6 +306,16 @@ SC_ENABLE_SHARED
SC_CONFIG_CFLAGS
+# Cross-compiling
+case ${host_alias} in
+*mingw32*)
+ TCL_EXE="tclsh"
+ ;;
+*)
+ TCL_EXE="TCL_LIBRARY=\"\${LIBRARY_DIR}\"; export TCL_LIBRARY; ./\${TCLSH}"
+ ;;
+esac
+
#------------------------------------------------------------------------
# Add stuff for zlib; note that this is mostly done in the makefile now
# as we just assume that the platform hasn't got a usable z.lib
@@ -425,6 +435,7 @@ AC_SUBST(TCL_MAJOR_VERSION)
AC_SUBST(TCL_MINOR_VERSION)
AC_SUBST(TCL_PATCH_LEVEL)
AC_SUBST(PKG_CFG_ARGS)
+AC_SUBST(TCL_EXE)
AC_SUBST(TCL_LIB_FILE)
AC_SUBST(TCL_LIB_FLAG)