summaryrefslogtreecommitdiffstats
path: root/win/configure.in
diff options
context:
space:
mode:
authornijtmans <nijtmans>2009-04-30 22:37:46 (GMT)
committernijtmans <nijtmans>2009-04-30 22:37:46 (GMT)
commitfc14cb7392349efcc99e221cefa6f328f0c9de2a (patch)
tree15f1273a872f54b2505f01408047a8932136b1b3 /win/configure.in
parent268de519126607c8691aea2e50f22ffee53dab6a (diff)
downloadtcl-fc14cb7392349efcc99e221cefa6f328f0c9de2a.zip
tcl-fc14cb7392349efcc99e221cefa6f328f0c9de2a.tar.gz
tcl-fc14cb7392349efcc99e221cefa6f328f0c9de2a.tar.bz2
Fix 64-bit detection for zlib on Win64
Diffstat (limited to 'win/configure.in')
-rw-r--r--win/configure.in18
1 files changed, 9 insertions, 9 deletions
diff --git a/win/configure.in b/win/configure.in
index 5c8a3f7..4f6356e 100644
--- a/win/configure.in
+++ b/win/configure.in
@@ -3,7 +3,7 @@
# generate the file "configure", which is run during Tcl installation
# to configure the system for the local environment.
#
-# RCS: @(#) $Id: configure.in,v 1.117 2009/02/16 22:56:14 nijtmans Exp $
+# RCS: @(#) $Id: configure.in,v 1.118 2009/04/30 22:37:46 nijtmans Exp $
AC_INIT(../generic/tcl.h)
AC_PREREQ(2.59)
@@ -338,6 +338,14 @@ SC_TCL_CFG_ENCODING
SC_ENABLE_SHARED
+#--------------------------------------------------------------------
+# The statements below define a collection of compile flags. This
+# macro depends on the value of SHARED_BUILD, and should be called
+# after SC_ENABLE_SHARED checks the configure switches.
+#--------------------------------------------------------------------
+
+SC_CONFIG_CFLAGS
+
#------------------------------------------------------------------------
# Add stuff for zlib; note that this is mostly done in the makefile now
# as we just assume that the platform hasn't got a usable z.lib
@@ -362,14 +370,6 @@ AS_IF([test "$tcl_ok" = "yes"], [
AC_DEFINE(HAVE_ZLIB, 1, [Is there an installed zlib?])
#--------------------------------------------------------------------
-# The statements below define a collection of compile flags. This
-# macro depends on the value of SHARED_BUILD, and should be called
-# after SC_ENABLE_SHARED checks the configure switches.
-#--------------------------------------------------------------------
-
-SC_CONFIG_CFLAGS
-
-#--------------------------------------------------------------------
# Set the default compiler switches based on the --enable-symbols
# option. This macro depends on C flags, and should be called
# after SC_CONFIG_CFLAGS macro is called.