summaryrefslogtreecommitdiffstats
path: root/win/configure.in
diff options
context:
space:
mode:
authorjan.nijtmans <nijtmans@users.sourceforge.net>2011-04-21 08:49:52 (GMT)
committerjan.nijtmans <nijtmans@users.sourceforge.net>2011-04-21 08:49:52 (GMT)
commit00ffa6c31944e0537fefd0dd70ca3aded31e6336 (patch)
tree170c82b377323ccaaa1d7543c9ca9c75ff3bf2c4 /win/configure.in
parent95c1b15bcdb4d087a64ead65b5b133d07513d5c8 (diff)
parent7d0a560d355159a6a8013f1edc7aedea37e7cf73 (diff)
downloadtcl-00ffa6c31944e0537fefd0dd70ca3aded31e6336.zip
tcl-00ffa6c31944e0537fefd0dd70ca3aded31e6336.tar.gz
tcl-00ffa6c31944e0537fefd0dd70ca3aded31e6336.tar.bz2
fix for [Bug 3288345]: Wrong Tcl_StatBufused on MinGW.
Make sure that all _WIN32 compilers use exactly the same layout for Tcl_StatBuf - the one used by MSVC6 - in all situations.
Diffstat (limited to 'win/configure.in')
-rw-r--r--win/configure.in19
1 files changed, 19 insertions, 0 deletions
diff --git a/win/configure.in b/win/configure.in
index 54727f8..7d43a38 100644
--- a/win/configure.in
+++ b/win/configure.in
@@ -225,6 +225,25 @@ if test "$tcl_cv_cast_to_union" = "yes"; then
[Defined when compiler supports casting to union type.])
fi
+# Check to see if struct _stat32i64 exists in mingw's sys/stat.h
+
+AC_CACHE_CHECK(struct _stat32i64,
+ tcl_struct_stat32i64,
+AC_TRY_COMPILE([
+#include <sys/types.h>
+#include <sys/stat.h>
+],
+[
+ struct _stat32i64 foo;
+],
+ tcl_struct_stat32i64=yes,
+ tcl_struct_stat32i64=no)
+)
+if test "$tcl_struct_stat32i64" = "yes" ; then
+ AC_DEFINE(HAVE_STRUCT_STAT32I64, 1,
+ [Defined when sys/stat.h has struct_stat32i64])
+fi
+
# See if declarations like FINDEX_INFO_LEVELS are
# missing from winbase.h. This is known to be