summaryrefslogtreecommitdiffstats
path: root/win/configure.in
diff options
context:
space:
mode:
authorhobbs <hobbs>2004-04-07 21:06:40 (GMT)
committerhobbs <hobbs>2004-04-07 21:06:40 (GMT)
commit2446d3e4c19bc8727f648e7fe66136a97247fcc5 (patch)
treed51ae145d88af896493d6933c4dff76e63a8d7dc /win/configure.in
parentbd25b5076fe69103b8dc106ff6930f61c702eda0 (diff)
downloadtcl-2446d3e4c19bc8727f648e7fe66136a97247fcc5.zip
tcl-2446d3e4c19bc8727f648e7fe66136a97247fcc5.tar.gz
tcl-2446d3e4c19bc8727f648e7fe66136a97247fcc5.tar.bz2
* win/configure:
* win/configure.in: define TCL_LIB_FLAG, TCL_BUILD_LIB_SPEC, TCL_LIB_SPEC and TCL_PACKAGE_PATH in tclConfig.sh.
Diffstat (limited to 'win/configure.in')
-rw-r--r--win/configure.in22
1 files changed, 17 insertions, 5 deletions
diff --git a/win/configure.in b/win/configure.in
index 04752a9..8638586 100644
--- a/win/configure.in
+++ b/win/configure.in
@@ -3,7 +3,7 @@
# generate the file "configure", which is run during Tcl installation
# to configure the system for the local environment.
#
-# RCS: @(#) $Id: configure.in,v 1.68.2.7 2004/02/13 01:38:02 hobbs Exp $
+# RCS: @(#) $Id: configure.in,v 1.68.2.8 2004/04/07 21:06:41 hobbs Exp $
AC_INIT(../generic/tcl.h)
AC_PREREQ(2.13)
@@ -307,10 +307,10 @@ eval "TCL_SRC_DIR=\"`cd $srcdir/..; pwd`\""
eval "TCL_DLL_FILE=tcl${VER}${DLLSUFFIX}"
eval "TCL_LIB_FILE=${LIBPREFIX}tcl$VER${LIBSUFFIX}"
-# FIMXE: These variables decls are missing
-#TCL_LIB_FLAG
-#TCL_BUILD_LIB_SPEC
-#TCL_LIB_SPEC
+
+eval "TCL_LIB_FLAG=\"-ltcl${VER}${LIBFLAGSUFFIX}\""
+eval "TCL_BUILD_LIB_SPEC=\"-L`pwd` ${TCL_LIB_FLAG}\""
+eval "TCL_LIB_SPEC=\"-L${libdir} ${TCL_LIB_FLAG}\""
eval "TCL_STUB_LIB_FILE=\"${LIBPREFIX}tclstub${VER}${LIBSUFFIX}\""
eval "TCL_STUB_LIB_FLAG=\"-ltclstub${VER}${LIBFLAGSUFFIX}\""
@@ -351,6 +351,18 @@ else
fi
fi
+#--------------------------------------------------------------------
+# The statements below define the symbol TCL_PACKAGE_PATH, which
+# gives a list of directories that may contain packages. The list
+# consists of one directory for machine-dependent binaries and
+# another for platform-independent scripts.
+#--------------------------------------------------------------------
+
+if test "$prefix" != "$exec_prefix"; then
+ TCL_PACKAGE_PATH="${libdir} ${prefix}/lib"
+else
+ TCL_PACKAGE_PATH="${prefix}/lib"
+fi
AC_SUBST(TCL_VERSION)
AC_SUBST(TCL_MAJOR_VERSION)