summaryrefslogtreecommitdiffstats
path: root/win/configure.in
diff options
context:
space:
mode:
authorjan.nijtmans <nijtmans@users.sourceforge.net>2011-05-11 15:23:01 (GMT)
committerjan.nijtmans <nijtmans@users.sourceforge.net>2011-05-11 15:23:01 (GMT)
commit645b420b4f7e757d9539b4a93d684a1965426c54 (patch)
tree2a85371878eb56ed38e1b54c68a1a9b3ad919ed1 /win/configure.in
parent6e968aa4b347f2486c5a7d0b8f72ba2bd5134495 (diff)
downloadtcl-645b420b4f7e757d9539b4a93d684a1965426c54.zip
tcl-645b420b4f7e757d9539b4a93d684a1965426c54.tar.gz
tcl-645b420b4f7e757d9539b4a93d684a1965426c54.tar.bz2
If your compiler already defines _WIN64, assume --enable-64bit
Diffstat (limited to 'win/configure.in')
-rw-r--r--win/configure.in14
1 files changed, 9 insertions, 5 deletions
diff --git a/win/configure.in b/win/configure.in
index 3e6561e..378ca5b 100644
--- a/win/configure.in
+++ b/win/configure.in
@@ -74,7 +74,7 @@ if test "${GCC}" = "yes" ; then
fi
#--------------------------------------------------------------------
-# Checks to see if the make progeam sets the $MAKE variable.
+# Checks to see if the make program sets the $MAKE variable.
#--------------------------------------------------------------------
AC_PROG_MAKE_SET
@@ -122,7 +122,7 @@ fi
#
# Check to see if the excpt.h include file provided contains the
# definition for EXCEPTION_DISPOSITION; if not, which is the case
-# with Cygwin's version as of 2002-04-10, define it to be int,
+# with Cygwin's version as of 2002-04-10, define it to be int,
# sufficient for getting the current code to work.
#
AC_CACHE_CHECK(for EXCEPTION_DISPOSITION support in include files,
@@ -281,7 +281,7 @@ SC_ENABLE_THREADS
SC_ENABLE_SHARED
#--------------------------------------------------------------------
-# The statements below define a collection of compile flags. This
+# The statements below define a collection of compile flags. This
# macro depends on the value of SHARED_BUILD, and should be called
# after SC_ENABLE_SHARED checks the configure switches.
#--------------------------------------------------------------------
@@ -289,7 +289,7 @@ SC_ENABLE_SHARED
SC_CONFIG_CFLAGS
#--------------------------------------------------------------------
-# Set the default compiler switches based on the --enable-symbols
+# Set the default compiler switches based on the --enable-symbols
# option. This macro depends on C flags, and should be called
# after SC_CONFIG_CFLAGS macro is called.
#--------------------------------------------------------------------
@@ -375,7 +375,7 @@ fi
# another for platform-independent scripts.
#--------------------------------------------------------------------
-if test "$prefix" != "$exec_prefix"; then
+if test "$prefix/lib" != "$libdir"; then
TCL_PACKAGE_PATH="${libdir} ${prefix}/lib"
else
TCL_PACKAGE_PATH="${prefix}/lib"
@@ -470,3 +470,7 @@ AC_SUBST(RC_DEFINES)
AC_SUBST(RES)
AC_OUTPUT(Makefile tclConfig.sh tcl.hpj)
+
+dnl Local Variables:
+dnl mode: autoconf;
+dnl End: