summaryrefslogtreecommitdiffstats
path: root/win/configure.in
diff options
context:
space:
mode:
authorjan.nijtmans <nijtmans@users.sourceforge.net>2011-08-15 13:51:21 (GMT)
committerjan.nijtmans <nijtmans@users.sourceforge.net>2011-08-15 13:51:21 (GMT)
commit788d06fcf3f90ffe105c77b3230be4f3fc1a62bd (patch)
treee86275675b2923b5745266c49a2cb0948a7d71a6 /win/configure.in
parentad9424f909976ade314404a44168e5c0eca6983e (diff)
parentfd1dbc086751dff48dbbbd4012e5f5ac0f46b06f (diff)
downloadtcl-788d06fcf3f90ffe105c77b3230be4f3fc1a62bd.zip
tcl-788d06fcf3f90ffe105c77b3230be4f3fc1a62bd.tar.gz
tcl-788d06fcf3f90ffe105c77b3230be4f3fc1a62bd.tar.bz2
mingw64 compiler warnings. Reverse the detection of struct _stat32i64,
otherwise when mingw doesn't have it, tclTest.c cannot be compiled
Diffstat (limited to 'win/configure.in')
-rw-r--r--win/configure.in14
1 files changed, 7 insertions, 7 deletions
diff --git a/win/configure.in b/win/configure.in
index ca5ef9c..791d96a 100644
--- a/win/configure.in
+++ b/win/configure.in
@@ -243,7 +243,7 @@ fi
# Check to see if struct _stat32i64 exists in mingw's sys/stat.h
-AC_CACHE_CHECK(struct _stat32i64,
+AC_CACHE_CHECK(if struct _stat32i64 missing,
tcl_struct_stat32i64,
AC_TRY_COMPILE([
#include <sys/types.h>
@@ -252,12 +252,12 @@ AC_TRY_COMPILE([
[
struct _stat32i64 foo;
],
- tcl_struct_stat32i64=yes,
- tcl_struct_stat32i64=no)
+ tcl_struct_stat32i64=no,
+ tcl_struct_stat32i64=yes)
)
if test "$tcl_struct_stat32i64" = "yes" ; then
- AC_DEFINE(HAVE_STRUCT_STAT32I64, 1,
- [Defined when sys/stat.h has struct_stat32i64])
+ AC_DEFINE(HAVE_NO_STRUCT_STAT32I64, 1,
+ [Defined when sys/stat.h is missing struct _stat32i64])
fi
@@ -345,7 +345,7 @@ AC_CHECK_TYPE([intptr_t], [
for tcl_cv_intptr_t in "int" "long" "long long" none; do
if test "$tcl_cv_intptr_t" != none; then
AC_COMPILE_IFELSE([AC_LANG_BOOL_COMPILE_TRY([AC_INCLUDES_DEFAULT],
- [[sizeof (void *) <= sizeof ($tcl_cv_intptr_t)]])],
+ [[sizeof (void *) <= sizeof ($tcl_cv_intptr_t)]])],
[tcl_ok=yes], [tcl_ok=no])
test "$tcl_ok" = yes && break; fi
done])
@@ -361,7 +361,7 @@ AC_CHECK_TYPE([uintptr_t], [
none; do
if test "$tcl_cv_uintptr_t" != none; then
AC_COMPILE_IFELSE([AC_LANG_BOOL_COMPILE_TRY([AC_INCLUDES_DEFAULT],
- [[sizeof (void *) <= sizeof ($tcl_cv_uintptr_t)]])],
+ [[sizeof (void *) <= sizeof ($tcl_cv_uintptr_t)]])],
[tcl_ok=yes], [tcl_ok=no])
test "$tcl_ok" = yes && break; fi
done])