summaryrefslogtreecommitdiffstats
path: root/win/configure.in
diff options
context:
space:
mode:
authorjan.nijtmans <nijtmans@users.sourceforge.net>2011-04-21 08:27:52 (GMT)
committerjan.nijtmans <nijtmans@users.sourceforge.net>2011-04-21 08:27:52 (GMT)
commit7d0a560d355159a6a8013f1edc7aedea37e7cf73 (patch)
tree488cf88073be0a3326790028a949d6385f029143 /win/configure.in
parent7f792b880aa3a8d14f800a2f2bf5af2df9fe36da (diff)
parent81582f76e6fa7e328f9ae6c92cf756e569565818 (diff)
downloadtcl-7d0a560d355159a6a8013f1edc7aedea37e7cf73.zip
tcl-7d0a560d355159a6a8013f1edc7aedea37e7cf73.tar.gz
tcl-7d0a560d355159a6a8013f1edc7aedea37e7cf73.tar.bz2
fix for [Bug 3288345]: Wrong Tcl_StatBuf used on MinGW.
Make sure that all _WIN32 compilers use exactly the same layout for Tcl_StatBuf - the one used by MSVC6 - in all situations.
Diffstat (limited to 'win/configure.in')
-rw-r--r--win/configure.in19
1 files changed, 19 insertions, 0 deletions
diff --git a/win/configure.in b/win/configure.in
index bbd4cd5..c589018 100644
--- a/win/configure.in
+++ b/win/configure.in
@@ -241,6 +241,25 @@ if test "$tcl_cv_cast_to_union" = "yes"; then
[Defined when compiler supports casting to union type.])
fi
+# Check to see if struct _stat32i64 exists in mingw's sys/stat.h
+
+AC_CACHE_CHECK(struct _stat32i64,
+ tcl_struct_stat32i64,
+AC_TRY_COMPILE([
+#include <sys/types.h>
+#include <sys/stat.h>
+],
+[
+ struct _stat32i64 foo;
+],
+ tcl_struct_stat32i64=yes,
+ tcl_struct_stat32i64=no)
+)
+if test "$tcl_struct_stat32i64" = "yes" ; then
+ AC_DEFINE(HAVE_STRUCT_STAT32I64, 1,
+ [Defined when sys/stat.h has struct_stat32i64])
+fi
+
# See if declarations like FINDEX_INFO_LEVELS are
# missing from winbase.h. This is known to be