summaryrefslogtreecommitdiffstats
path: root/win/configure.in
diff options
context:
space:
mode:
authorjan.nijtmans <nijtmans@users.sourceforge.net>2011-04-21 08:08:36 (GMT)
committerjan.nijtmans <nijtmans@users.sourceforge.net>2011-04-21 08:08:36 (GMT)
commit81582f76e6fa7e328f9ae6c92cf756e569565818 (patch)
treeb0b93eb5ba78408fab27e7c5e6c0982407cc140a /win/configure.in
parentaed831f6a1a96de6e8f56e5600f4e9584fefd224 (diff)
downloadtcl-81582f76e6fa7e328f9ae6c92cf756e569565818.zip
tcl-81582f76e6fa7e328f9ae6c92cf756e569565818.tar.gz
tcl-81582f76e6fa7e328f9ae6c92cf756e569565818.tar.bz2
fix for [Bug 3288345]: Wrong Tcl_StatBufused on MinGW.
Make sure that all _WIN32 compilers use exactly the same layout for Tcl_StatBuf - the one used by MSVC6 - in all situations.
Diffstat (limited to 'win/configure.in')
-rw-r--r--win/configure.in19
1 files changed, 19 insertions, 0 deletions
diff --git a/win/configure.in b/win/configure.in
index 1b6a843..3e6561e 100644
--- a/win/configure.in
+++ b/win/configure.in
@@ -240,6 +240,25 @@ if test "$tcl_cv_cast_to_union" = "yes"; then
[Defined when compiler supports casting to union type.])
fi
+# Check to see if struct _stat32i64 exists in mingw's sys/stat.h
+
+AC_CACHE_CHECK(struct _stat32i64,
+ tcl_struct_stat32i64,
+AC_TRY_COMPILE([
+#include <sys/types.h>
+#include <sys/stat.h>
+],
+[
+ struct _stat32i64 foo;
+],
+ tcl_struct_stat32i64=yes,
+ tcl_struct_stat32i64=no)
+)
+if test "$tcl_struct_stat32i64" = "yes" ; then
+ AC_DEFINE(HAVE_STRUCT_STAT32I64, 1,
+ [Defined when sys/stat.h has struct_stat32i64])
+fi
+
#--------------------------------------------------------------------
# Determines the correct binary file extension (.o, .obj, .exe etc.)