summaryrefslogtreecommitdiffstats
path: root/win/configure.in
diff options
context:
space:
mode:
authorjan.nijtmans <nijtmans@users.sourceforge.net>2011-04-08 06:31:54 (GMT)
committerjan.nijtmans <nijtmans@users.sourceforge.net>2011-04-08 06:31:54 (GMT)
commit9d0b3f045b6c187e33ae5e704d5d78b4041102cd (patch)
tree5d4980e2f59ba8ad7514a6693a6ef88e3db90bd2 /win/configure.in
parent886982eaaeb8e06d1b44c7cf39b1fa4d4c38bffc (diff)
downloadtcl-9d0b3f045b6c187e33ae5e704d5d78b4041102cd.zip
tcl-9d0b3f045b6c187e33ae5e704d5d78b4041102cd.tar.gz
tcl-9d0b3f045b6c187e33ae5e704d5d78b4041102cd.tar.bz2
fix for [Bug 3280043]: win2k: unresolved DLL imports
Diffstat (limited to 'win/configure.in')
-rw-r--r--win/configure.in15
1 files changed, 15 insertions, 0 deletions
diff --git a/win/configure.in b/win/configure.in
index 4e9f2db..b286537 100644
--- a/win/configure.in
+++ b/win/configure.in
@@ -291,6 +291,21 @@ if test "$tcl_cv_intrinsics" = "yes"; then
[Defined when the compilers supports intrinsics])
fi
+# See if the <wspiapi.h> header file is present
+
+AC_CACHE_CHECK(for wspiapi.h,
+ tcl_have_wspiapi_h,
+AC_TRY_COMPILE([
+#include <wspiapi.h>
+], [],
+ tcl_have_wspiapi_h=yes,
+ tcl_have_wspiapi_h=no)
+)
+if test "tcl_have_wspiapi_h" = "yes"; then
+ AC_DEFINE(HAVE_WSPIAPI_H, 1,
+ [Defined when wspiapi.h exists])
+fi
+
#--------------------------------------------------------------------
# Determines the correct binary file extension (.o, .obj, .exe etc.)
#--------------------------------------------------------------------