summaryrefslogtreecommitdiffstats
path: root/win/configure.in
diff options
context:
space:
mode:
authorjan.nijtmans <nijtmans@users.sourceforge.net>2011-08-15 13:46:34 (GMT)
committerjan.nijtmans <nijtmans@users.sourceforge.net>2011-08-15 13:46:34 (GMT)
commitfd1dbc086751dff48dbbbd4012e5f5ac0f46b06f (patch)
tree42cd5987cfd935b78f4d0ea5297658a6801eb248 /win/configure.in
parent092dd70e63fd7c5fcc9526b06c1242322378d492 (diff)
downloadtcl-fd1dbc086751dff48dbbbd4012e5f5ac0f46b06f.zip
tcl-fd1dbc086751dff48dbbbd4012e5f5ac0f46b06f.tar.gz
tcl-fd1dbc086751dff48dbbbd4012e5f5ac0f46b06f.tar.bz2
[Bug 3388350] mingw64 compiler warnings.
Reverse the detection of struct _stat32i64, otherwise when mingw doesn't have it, tclTest.c cannot be compiled
Diffstat (limited to 'win/configure.in')
-rw-r--r--win/configure.in10
1 files changed, 5 insertions, 5 deletions
diff --git a/win/configure.in b/win/configure.in
index 378ca5b..47b6a4f 100644
--- a/win/configure.in
+++ b/win/configure.in
@@ -242,7 +242,7 @@ fi
# Check to see if struct _stat32i64 exists in mingw's sys/stat.h
-AC_CACHE_CHECK(struct _stat32i64,
+AC_CACHE_CHECK(if struct _stat32i64 missing,
tcl_struct_stat32i64,
AC_TRY_COMPILE([
#include <sys/types.h>
@@ -251,12 +251,12 @@ AC_TRY_COMPILE([
[
struct _stat32i64 foo;
],
- tcl_struct_stat32i64=yes,
- tcl_struct_stat32i64=no)
+ tcl_struct_stat32i64=no,
+ tcl_struct_stat32i64=yes)
)
if test "$tcl_struct_stat32i64" = "yes" ; then
- AC_DEFINE(HAVE_STRUCT_STAT32I64, 1,
- [Defined when sys/stat.h has struct_stat32i64])
+ AC_DEFINE(HAVE_NO_STRUCT_STAT32I64, 1,
+ [Defined when sys/stat.h is missing struct _stat32i64])
fi