summaryrefslogtreecommitdiffstats
path: root/win/configure.in
diff options
context:
space:
mode:
authornijtmans <nijtmans>2009-02-16 22:56:14 (GMT)
committernijtmans <nijtmans>2009-02-16 22:56:14 (GMT)
commit030c53711206ecdcbb31ae7d50b8dac10e53a8d6 (patch)
tree7dda0e36e5d56225b36f550e04f223f6bc75ce74 /win/configure.in
parenteccf49ac252fc88532e302433a4cc5caef4ddd9f (diff)
downloadtcl-030c53711206ecdcbb31ae7d50b8dac10e53a8d6.zip
tcl-030c53711206ecdcbb31ae7d50b8dac10e53a8d6.tar.gz
tcl-030c53711206ecdcbb31ae7d50b8dac10e53a8d6.tar.bz2
fix [Feature Request 2605263] use official
zlib build.
Diffstat (limited to 'win/configure.in')
-rw-r--r--win/configure.in18
1 files changed, 17 insertions, 1 deletions
diff --git a/win/configure.in b/win/configure.in
index 33f40cc..5c8a3f7 100644
--- a/win/configure.in
+++ b/win/configure.in
@@ -3,7 +3,7 @@
# generate the file "configure", which is run during Tcl installation
# to configure the system for the local environment.
#
-# RCS: @(#) $Id: configure.in,v 1.116 2009/01/16 20:44:25 dgp Exp $
+# RCS: @(#) $Id: configure.in,v 1.117 2009/02/16 22:56:14 nijtmans Exp $
AC_INIT(../generic/tcl.h)
AC_PREREQ(2.59)
@@ -343,6 +343,22 @@ SC_ENABLE_SHARED
# as we just assume that the platform hasn't got a usable z.lib
#------------------------------------------------------------------------
+AS_IF([test "$do64bit" = "yes"], [
+ tcl_ok=no
+], [
+AS_IF([test "${enable_shared+set}" = "set"], [
+ enableval="$enable_shared"
+ tcl_ok=$enableval
+], [
+ tcl_ok=yes
+])
+])
+AS_IF([test "$tcl_ok" = "yes"], [
+ AC_SUBST(ZLIB_DLL_FILE,[\${ZLIB_DLL_FILE}])
+ AC_SUBST(ZLIB_LIBS,[\${ZLIB_DIR}/win32/zdll.lib])
+], [
+ AC_SUBST(ZLIB_OBJS,[\${ZLIB_OBJS}])
+])
AC_DEFINE(HAVE_ZLIB, 1, [Is there an installed zlib?])
#--------------------------------------------------------------------