summaryrefslogtreecommitdiffstats
path: root/win/configure.in
diff options
context:
space:
mode:
authordgp <dgp@users.sourceforge.net>2012-08-20 14:14:00 (GMT)
committerdgp <dgp@users.sourceforge.net>2012-08-20 14:14:00 (GMT)
commit56ab72d069fc6871ecfd285bb07e4670bcc5db4a (patch)
tree7a0312e58d298d09068fef5d9311e409cd47f771 /win/configure.in
parent23754cbbc81ac0eda71610fe3737a8bc8ae31c65 (diff)
parenteb9bcac9c6ae30bb3e5f6bc298ee8238927a93e1 (diff)
downloadtcl-56ab72d069fc6871ecfd285bb07e4670bcc5db4a.zip
tcl-56ab72d069fc6871ecfd285bb07e4670bcc5db4a.tar.gz
tcl-56ab72d069fc6871ecfd285bb07e4670bcc5db4a.tar.bz2
merge trunk
Diffstat (limited to 'win/configure.in')
-rw-r--r--win/configure.in8
1 files changed, 6 insertions, 2 deletions
diff --git a/win/configure.in b/win/configure.in
index 950fca1..9145ff3 100644
--- a/win/configure.in
+++ b/win/configure.in
@@ -120,7 +120,7 @@ esac
# as we just assume that the platform hasn't got a usable z.lib
#------------------------------------------------------------------------
-AS_IF([test "$do64bit" = "yes"], [
+AS_IF([test "$do64bit" = "yes" && test "$GCC" != "yes"], [
tcl_ok=no
], [
AS_IF([test "${enable_shared+set}" = "set"], [
@@ -132,7 +132,11 @@ AS_IF([test "${enable_shared+set}" = "set"], [
])
AS_IF([test "$tcl_ok" = "yes"], [
AC_SUBST(ZLIB_DLL_FILE,[\${ZLIB_DLL_FILE}])
- AC_SUBST(ZLIB_LIBS,[\${ZLIB_DIR}/win32/zdll.lib])
+ AS_IF([test "$do64bit" = "yes"], [
+ AC_SUBST(ZLIB_LIBS,[\${ZLIB_DIR}/win64/zdll.lib])
+ ], [
+ AC_SUBST(ZLIB_LIBS,[\${ZLIB_DIR}/win32/zdll.lib])
+ ])
], [
AC_SUBST(ZLIB_OBJS,[\${ZLIB_OBJS}])
AC_DEFINE_UNQUOTED(NO_VIZ, 1)