summaryrefslogtreecommitdiffstats
path: root/win/configure.in
diff options
context:
space:
mode:
authormdejong <mdejong>2003-04-03 02:24:11 (GMT)
committermdejong <mdejong>2003-04-03 02:24:11 (GMT)
commit18f17ff4b787b7183764a21bc157390857b95d5f (patch)
tree63e94423a024dd237a38554c56a2b4ccf82b0cc3 /win/configure.in
parent18d98caf85ba0de87a91682af5678f6bd580a778 (diff)
downloadtcl-18f17ff4b787b7183764a21bc157390857b95d5f.zip
tcl-18f17ff4b787b7183764a21bc157390857b95d5f.tar.gz
tcl-18f17ff4b787b7183764a21bc157390857b95d5f.tar.bz2
* win/configure: Regen.
* win/configure.in: Set stub lib flag based on new LIBFLAGSUFFIX variable. * win/tcl.m4 (SC_CONFIG_CFLAGS): Set new LIBFLAGSUFFIX that works like LIBSUFFIX, it is used when creating library names. The previous implementation would generate -ltclstub85 instead of -ltclstub85s when configured with --disable-shared.
Diffstat (limited to 'win/configure.in')
-rw-r--r--win/configure.in4
1 files changed, 2 insertions, 2 deletions
diff --git a/win/configure.in b/win/configure.in
index 5678f37..c88ba3d 100644
--- a/win/configure.in
+++ b/win/configure.in
@@ -3,7 +3,7 @@
# generate the file "configure", which is run during Tcl installation
# to configure the system for the local environment.
#
-# RCS: @(#) $Id: configure.in,v 1.71 2003/03/19 03:09:43 mdejong Exp $
+# RCS: @(#) $Id: configure.in,v 1.72 2003/04/03 02:24:12 mdejong Exp $
AC_INIT(../generic/tcl.h)
AC_PREREQ(2.57)
@@ -329,7 +329,7 @@ eval "TCL_LIB_FILE=${LIBPREFIX}tcl$VER${LIBSUFFIX}"
#TCL_LIB_SPEC
eval "TCL_STUB_LIB_FILE=\"${LIBPREFIX}tclstub${VER}${LIBSUFFIX}\""
-eval "TCL_STUB_LIB_FLAG=\"-ltclstub${VER}${TCL_DBGX}\""
+eval "TCL_STUB_LIB_FLAG=\"-ltclstub${VER}${LIBFLAGSUFFIX}\""
eval "TCL_BUILD_STUB_LIB_SPEC=\"-L`pwd` ${TCL_STUB_LIB_FLAG}\""
eval "TCL_STUB_LIB_SPEC=\"-L${libdir} ${TCL_STUB_LIB_FLAG}\""
eval "TCL_BUILD_STUB_LIB_PATH=\"`pwd`/${TCL_STUB_LIB_FILE}\""