summaryrefslogtreecommitdiffstats
path: root/win/configure.in
diff options
context:
space:
mode:
authormdejong <mdejong>2002-01-11 20:46:34 (GMT)
committermdejong <mdejong>2002-01-11 20:46:34 (GMT)
commitbdf455ff3aa47ec53602eea5ca50874e0287a25e (patch)
tree0b0b928524c26e83414fa22d4f5ba0c07731e223 /win/configure.in
parent5eb022d210ab41926b0be17e63347e5e864a1831 (diff)
downloadtcl-bdf455ff3aa47ec53602eea5ca50874e0287a25e.zip
tcl-bdf455ff3aa47ec53602eea5ca50874e0287a25e.tar.gz
tcl-bdf455ff3aa47ec53602eea5ca50874e0287a25e.tar.bz2
* unix/configure: Regen.
* unix/configure.in: * win/configure: Regen. * win/configure.in: Use ${libdir} instead of ${exec_prefix}/lib to properly support the --libdir option to configure. [Bug 489370]
Diffstat (limited to 'win/configure.in')
-rw-r--r--win/configure.in8
1 files changed, 5 insertions, 3 deletions
diff --git a/win/configure.in b/win/configure.in
index 4d81f5b..e24b8ef 100644
--- a/win/configure.in
+++ b/win/configure.in
@@ -3,7 +3,7 @@
# generate the file "configure", which is run during Tcl installation
# to configure the system for the local environment.
#
-# RCS: @(#) $Id: configure.in,v 1.45 2001/11/08 03:07:21 mdejong Exp $
+# RCS: @(#) $Id: configure.in,v 1.46 2002/01/11 20:46:34 mdejong Exp $
AC_INIT(../generic/tcl.h)
@@ -35,6 +35,8 @@ fi
if test "${exec_prefix}" = "NONE"; then
exec_prefix=$prefix
fi
+# libdir must be a fully qualified path (not ${exec_prefix}/lib)
+eval libdir="$libdir"
#------------------------------------------------------------------------
# Standard compiler checks
@@ -153,9 +155,9 @@ eval "TCL_LIB_FILE=${LIBPREFIX}tcl$VER${LIBSUFFIX}"
eval "TCL_STUB_LIB_FILE=\"${LIBPREFIX}tclstub${VER}${LIBSUFFIX}\""
eval "TCL_STUB_LIB_FLAG=\"-ltclstub${VER}${TCL_DBGX}\""
eval "TCL_BUILD_STUB_LIB_SPEC=\"-L`pwd` ${TCL_STUB_LIB_FLAG}\""
-eval "TCL_STUB_LIB_SPEC=\"-L${exec_prefix}/lib ${TCL_STUB_LIB_FLAG}\""
+eval "TCL_STUB_LIB_SPEC=\"-L${libdir} ${TCL_STUB_LIB_FLAG}\""
eval "TCL_BUILD_STUB_LIB_PATH=\"`pwd`/${TCL_STUB_LIB_FILE}\""
-eval "TCL_STUB_LIB_PATH=\"${exec_prefix}/lib/${TCL_STUB_LIB_FILE}\""
+eval "TCL_STUB_LIB_PATH=\"${libdir}/${TCL_STUB_LIB_FILE}\""
# Install time header dir can be set via --includedir
eval "TCL_INCLUDE_SPEC=\"-I${includedir}\""