summaryrefslogtreecommitdiffstats
path: root/win/configure.in
diff options
context:
space:
mode:
authormdejong <mdejong>2004-03-05 21:27:45 (GMT)
committermdejong <mdejong>2004-03-05 21:27:45 (GMT)
commitc64a37e036445bb15f91d7b7a22b1269417e4c3d (patch)
treee0a3aca20ec80a771ea4b05bbc37eab810a95dea /win/configure.in
parentfcfbbfde29f5232f5f08035190b90c94a8c2a89a (diff)
downloadtcl-c64a37e036445bb15f91d7b7a22b1269417e4c3d.zip
tcl-c64a37e036445bb15f91d7b7a22b1269417e4c3d.tar.gz
tcl-c64a37e036445bb15f91d7b7a22b1269417e4c3d.tar.bz2
* win/configure: Regen.
* win/configure.in: Check for define of MWMO_ALERTABLE in winuser.h. * win/tclWinPort.h: If MWMO_ALERTABLE is not defined in winuser.h then define it. This is needed for Mingw.
Diffstat (limited to 'win/configure.in')
-rw-r--r--win/configure.in23
1 files changed, 22 insertions, 1 deletions
diff --git a/win/configure.in b/win/configure.in
index 170672d..8f8b064 100644
--- a/win/configure.in
+++ b/win/configure.in
@@ -3,7 +3,7 @@
# generate the file "configure", which is run during Tcl installation
# to configure the system for the local environment.
#
-# RCS: @(#) $Id: configure.in,v 1.77 2004/03/02 00:42:51 hobbs Exp $
+# RCS: @(#) $Id: configure.in,v 1.78 2004/03/05 21:27:46 mdejong Exp $
AC_INIT(../generic/tcl.h)
AC_PREREQ(2.57)
@@ -287,6 +287,27 @@ if test "$tcl_cv_findex_enums" = "no"; then
[Defined when enums are missing from winbase.h])
fi
+# See if MWMO_ALERTABLE is missing from winuser.h
+# This is known to be a problem with Mingw.
+
+AC_CACHE_CHECK(for MWMO_ALERTABLE in winuser.h,
+ tcl_cv_mwmo_alertable,
+AC_TRY_COMPILE([
+#define WIN32_LEAN_AND_MEAN
+#include <windows.h>
+#undef WIN32_LEAN_AND_MEAN
+],
+[
+ int i = MWMO_ALERTABLE;
+],
+ tcl_cv_mwmo_alertable=yes,
+ tcl_cv_mwmo_alertable=no)
+)
+if test "$tcl_cv_mwmo_alertable" = "no"; then
+ AC_DEFINE(HAVE_NO_MWMO_ALERTABLE, 1,
+ [Defined when MWMO_ALERTABLE is missing from winuser.h])
+fi
+
#--------------------------------------------------------------------
# Determines the correct binary file extension (.o, .obj, .exe etc.)
#--------------------------------------------------------------------