summaryrefslogtreecommitdiffstats
path: root/tools/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'tools/configure.in')
-rw-r--r--tools/configure.in20
1 files changed, 18 insertions, 2 deletions
diff --git a/tools/configure.in b/tools/configure.in
index 8d048c8..f5fa48d 100644
--- a/tools/configure.in
+++ b/tools/configure.in
@@ -2,11 +2,24 @@ dnl This file is an input file used by the GNU "autoconf" program to
dnl generate the file "configure", which is run to configure the
dnl Makefile in this directory.
AC_INIT(man2tcl.c)
-# RCS: @(#) $Id: configure.in,v 1.2 1998/09/14 18:40:15 stanton Exp $
+# RCS: @(#) $Id: configure.in,v 1.2.2.1 1999/02/19 02:17:04 stanton Exp $
# Recover information that Tcl computed with its configure script.
-. ../unix/tclConfig.sh
+#--------------------------------------------------------------------
+# See if there was a command-line option for where Tcl is; if
+# not, assume that its top-level directory is a sibling of ours.
+#--------------------------------------------------------------------
+
+AC_ARG_WITH(tcl, [ --with-tcl=DIR use Tcl 8.0 binaries from DIR], TCL_BIN_DIR=$withval, TCL_BIN_DIR=`cd ../../tcl8.0$TK_PATCH_LEVEL/unix; pwd`)
+if test ! -d $TCL_BIN_DIR; then
+ AC_MSG_ERROR(Tcl directory $TCL_BIN_DIR doesn't exist)
+fi
+if test ! -f $TCL_BIN_DIR/tclConfig.sh; then
+ AC_MSG_ERROR(There's no tclConfig.sh in $TCL_BIN_DIR; perhaps you didn't specify the Tcl *build* directory (not the toplevel Tcl directory) or you forgot to configure Tcl?)
+fi
+
+. $TCL_BIN_DIR/tclConfig.sh
TCL_WIN_VERSION=$TCL_MAJOR_VERSION$TCL_MINOR_VERSION
AC_SUBST(TCL_WIN_VERSION)
@@ -14,5 +27,8 @@ CC=$TCL_CC
AC_SUBST(CC)
AC_SUBST(TCL_VERSION)
AC_SUBST(TCL_PATCH_LEVEL)
+AC_SUBST(TCL_SRC_DIR)
+AC_SUBST(TCL_BIN_DIR)
AC_OUTPUT(Makefile)
+AC_OUTPUT(tcl.hpj)