summaryrefslogtreecommitdiffstats
path: root/unix/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'unix/configure.in')
-rw-r--r--unix/configure.in6
1 files changed, 3 insertions, 3 deletions
diff --git a/unix/configure.in b/unix/configure.in
index 27ad5f4..f57d3dc 100644
--- a/unix/configure.in
+++ b/unix/configure.in
@@ -278,7 +278,7 @@ AC_CHECK_FUNC(memmove, , [
#--------------------------------------------------------------------
SC_TCL_CHECK_BROKEN_FUNC(strstr, [
- extern int strstr();
+ extern char *strstr(const char *, const char *);
exit(strstr("\0test", "test") ? 1 : 0);
])
@@ -289,7 +289,7 @@ SC_TCL_CHECK_BROKEN_FUNC(strstr, [
#--------------------------------------------------------------------
SC_TCL_CHECK_BROKEN_FUNC(strtoul, [
- extern int strtoul();
+ extern unsigned long strtoul(const char *, char **, int);
char *term, *string = "0";
exit(strtoul(string,&term,0) != 0 || term != string+1);
])
@@ -300,7 +300,7 @@ SC_TCL_CHECK_BROKEN_FUNC(strtoul, [
#--------------------------------------------------------------------
SC_TCL_CHECK_BROKEN_FUNC(strtod, [
- extern double strtod();
+ extern double strtod(const char *, char **);
char *term, *string = " +69";
exit(strtod(string,&term) != 69 || term != string+4);
])