summaryrefslogtreecommitdiffstats
path: root/unix/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'unix/configure.in')
-rw-r--r--unix/configure.in8
1 files changed, 5 insertions, 3 deletions
diff --git a/unix/configure.in b/unix/configure.in
index 87731a1..473758d 100644
--- a/unix/configure.in
+++ b/unix/configure.in
@@ -705,11 +705,13 @@ AC_CACHE_CHECK([if the C stack grows upwards in memory], tcl_cv_stack_grows_up,
AC_TRY_RUN([
int StackGrowsUp(int *parent) {
int here;
- return (&here < parent);
+ if (parent)
+ return (&here < parent);
+ else
+ return StackGrowsUp(&here);
}
int main (int argc, char *argv[]) {
- int foo;
- return StackGrowsUp(&foo);
+ return StackGrowsUp(0);
}
], tcl_cv_stack_grows_up=yes, tcl_cv_stack_grows_up=no,
tcl_cv_stack_grows_up=unknown)])