summaryrefslogtreecommitdiffstats
path: root/unix/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'unix/configure.in')
-rw-r--r--unix/configure.in7
1 files changed, 6 insertions, 1 deletions
diff --git a/unix/configure.in b/unix/configure.in
index e22a7d3..f47b882 100644
--- a/unix/configure.in
+++ b/unix/configure.in
@@ -491,6 +491,12 @@ SC_ENABLE_LANGINFO
AC_CHECK_FUNCS(chflags)
#--------------------------------------------------------------------
+# Check for support of pthread_atfork function
+#--------------------------------------------------------------------
+
+AC_CHECK_FUNCS(pthread_atfork)
+
+#--------------------------------------------------------------------
# Check for support of isnan() function or macro
#--------------------------------------------------------------------
@@ -513,7 +519,6 @@ if test "`uname -s`" = "Darwin" ; then
if test $tcl_corefoundation = yes; then
AC_CHECK_HEADERS(libkern/OSAtomic.h)
AC_CHECK_FUNCS(OSSpinLockLock)
- AC_CHECK_FUNCS(pthread_atfork)
fi
AC_DEFINE(USE_VFORK, 1, [Should we use vfork() instead of fork()?])
AC_DEFINE(TCL_DEFAULT_ENCODING, "utf-8",