summaryrefslogtreecommitdiffstats
path: root/win/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'win/configure.ac')
-rw-r--r--win/configure.ac14
1 files changed, 14 insertions, 0 deletions
diff --git a/win/configure.ac b/win/configure.ac
index 173efbf..2761cfd 100644
--- a/win/configure.ac
+++ b/win/configure.ac
@@ -371,6 +371,19 @@ else
RC_DEFINES=""
fi
+#--------------------------------------------------------------------
+# The statements below define the symbol TCL_PACKAGE_PATH, which
+# gives a list of directories that may contain packages. The list
+# consists of one directory for machine-dependent binaries and
+# another for platform-independent scripts.
+#--------------------------------------------------------------------
+
+if test "$prefix/lib" != "$libdir"; then
+ TCL_PACKAGE_PATH="${libdir};${prefix}\\lib"
+else
+ TCL_PACKAGE_PATH="${prefix}\\lib"
+fi
+
# The tclsh.exe.manifest requires these
# TCL_WIN_VERSION is the 4 dotted pair Windows version format which needs
# the release level, and must account for interim release versioning
@@ -457,6 +470,7 @@ AC_SUBST(TCL_LD_SEARCH_FLAGS)
AC_SUBST(TCL_BUILD_EXP_FILE)
AC_SUBST(TCL_EXP_FILE)
AC_SUBST(DL_LIBS)
+AC_SUBST(TCL_PACKAGE_PATH)
# win only
AC_SUBST(TCL_DDE_VERSION)