Commit message (Collapse) | Author | Age | Files | Lines | |
---|---|---|---|---|---|
* | merge trunktip_445_fork | dgp | 2016-04-05 | 4 | -16/+13 |
|\ | |||||
| * | Rename UtfCount() to TclUtfCount() and use it in more places. Suggested by ↵ | jan.nijtmans | 2016-04-05 | 3 | -16/+11 |
| | | | | | | | | pspjuth here: [e99a79a32650e7e5] | ||||
* | | merge trunk | dgp | 2016-04-04 | 3 | -11/+81 |
|\ \ | |/ | |||||
| * | [47ac84309b] Clear up a bunch of problems with [lreplace]. It now does ↵ | dkf | 2016-04-04 | 3 | -11/+81 |
| |\ | | | | | | | | | | nothing more gracefully, and properly ensures that the compiled and interpreted versions work the same. Thanks to aspect for his work on this. | ||||
| | * | [47ac84309b] Clear up a bunch of problems with [lreplace]. It now does ↵potential_incompatibility | dkf | 2016-04-04 | 3 | -11/+81 |
| | |\ | | | | | | | | | | | | | nothing more gracefully, and properly ensures that the compiled and interpreted versions work the same. Thanks to aspect for his work on this. | ||||
| | | * | [47ac84309b] Import of aspect's branch from his personal repository on ↵aspect_lreplace_cleanup | dkf | 2016-03-30 | 3 | -11/+81 |
| | | | | | | | | | | | | | | | | chiselapp. | ||||
* | | | | Use new routine TclGetLambdaFromObj to better isolate the "lambdaExpr" ObjType. | dgp | 2016-04-04 | 3 | -46/+72 |
| | | | | | | | | | | | | Then convert it to use the proposed routines. | ||||
* | | | | Use simple name for file static struct. | dgp | 2016-04-04 | 1 | -12/+8 |
| | | | | |||||
* | | | | merge trunk | dgp | 2016-04-04 | 1 | -63/+9 |
|\ \ \ \ | |/ / / | |||||
| * | | | Revise "parsedVarName" Tcl_ObjType to eliminated unnecessary parts and | dgp | 2016-04-04 | 1 | -63/+9 |
| |\ \ \ | | | | | | | | | | | to reduce string copying. | ||||
| | * | | | There's a "parsedVarName" Tcl_ObjType that remembers how a variable namedgp_revise_parsedvarnametype | dgp | 2016-03-28 | 1 | -11/+34 |
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | breaks down into the name of an array and the name of an element. It has been storing them in an intrep as a Tcl_Obj holding the array name and an allocated string holding the element name. This branch revises the intrep strategy to use Tcl_Obj's to hold both parts. This reduces copying and seems to simplify the code. Also "nulled out" the UpdateStringProc for the type which can never be called. I think this is a better answer, but I'd like any other informed opinions. | ||||
* | | | | | Revise "nsName" ObjType to use proposed routines. | dgp | 2016-04-04 | 1 | -27/+38 |
| | | | | | |||||
* | | | | | Revise "instname" ObjType to use proposed routines | dgp | 2016-04-04 | 1 | -7/+24 |
| | | | | | |||||
* | | | | | Revise "regexp" Tcl_ObjType to use proposed routines. | dgp | 2016-04-04 | 1 | -28/+32 |
| | | | | | |||||
* | | | | | merge trunk | dgp | 2016-04-04 | 12 | -67/+204 |
|\ \ \ \ \ | |/ / / / | |||||
| * | | | | merge 8.6 | dgp | 2016-04-04 | 2 | -4/+23 |
| |\ \ \ \ | | | |/ / | | |/| | | |||||
| | * | | | Corrections to compression stream flushing to make Tk generate PNGs ↵ | dkf | 2016-04-04 | 2 | -4/+23 |
| | |\ \ \ | | | | | | | | | | | | | | | | | | | correctly. Tk bug [9eb55debc5]. | ||||
| | | * | | | Was handling the flushing at the end of the stream wrongly.tk_bug_9eb55debc5 | dkf | 2016-04-04 | 2 | -8/+9 |
| | | | | | | |||||
| | | * | | | Working on fixing problem with short reads from compressing streams that ↵ | dkf | 2016-04-03 | 1 | -0/+18 |
| | |/ / / | | | | | | | | | | | | | | | | breaks PNG creation in Tk. | ||||
| * | | | | close fork | dgp | 2016-04-04 | 3 | -11/+117 |
| |\ \ \ \ | |||||
| | * \ \ \ | Merge tip-444micro_opt | gahr | 2016-04-04 | 3 | -11/+117 |
| | |\ \ \ \ | |||||
| | | * \ \ \ | merge trunktip_444 | gahr | 2016-04-04 | 225 | -19575/+12192 |
| | | |\ \ \ \ | | | |/ / / / | | |/| | | | | |||||
| | * | | | | | micro-optimization from drh-micro-optimization branch: Knock perhaps 1% off ↵ | jan.nijtmans | 2016-04-04 | 1 | -9/+11 |
| | |\ \ \ \ \ | | | | | | | | | | | | | | | | | | | | | | | | | execution time: guard on TclAsyncReady more efficient when decrementing to zero. | ||||
| | | * | | | | | Knock perhaps 1% off execution time: guard on TclAsyncReady more efficient ↵ | dkf | 2015-10-23 | 1 | -9/+11 |
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | when decrementing to zero. | ||||
| | | * | | | | | fix typo in micro-optimization TclpInitThreadAlloc | Kevin B Kenny | 2015-10-22 | 1 | -1/+1 |
| | | | | | | | | |||||
| | | * | | | | | Turn off NRE asserts by default. About a 5% speedup on [clock format]. | dkf | 2015-10-22 | 3 | -7/+3 |
| | | | | | | | | |||||
| | | * | | | | | Micro-optimization: remove double checked lock from TclGetAllocCache in ↵ | Kevin B Kenny | 2015-10-21 | 4 | -35/+31 |
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | favour of initialization in TclInitSubsystems | ||||
| | | | * | | | | merge trunk | gahr | 2016-03-03 | 133 | -894/+848 |
| | | | |\ \ \ \ | |||||
| | | | * | | | | | Clarify that weekends are intended as Saturdays and Sundays | gahr | 2016-03-03 | 1 | -1/+1 |
| | | | | | | | | | |||||
| | | | * | | | | | More comprehensive tests adding and subtracting week-days | gahr | 2016-02-24 | 1 | -10/+23 |
| | | | | | | | | | |||||
| | | | * | | | | | merge trunk | gahr | 2016-02-23 | 2 | -16/+26 |
| | | | |\ \ \ \ \ | |||||
| | | | * | | | | | | Make sure that adding 0 weekdays doesn't result in going back in time | gahr | 2016-02-23 | 2 | -1/+10 |
| | | | | | | | | | | |||||
| | | | * | | | | | | [5f71353740] Support the "weekdays" unit in [clock add] | gahr | 2016-02-17 | 3 | -11/+95 |
| | | | | | | | | | | |||||
| * | | | | | | | | | Merge *both* commits to get the TclAsyncReady optimization. Without | dgp | 2016-04-04 | 1 | -10/+17 |
| |/ / / / / / / / | | | | | | | | | | | | | | | | | | | both parts, the test interp-34.3.1 hangs. | ||||
| * | | | | | | | | RFE [0ef5e653ff4caf5f896ec1182e0aac38ab9a0c46|0ef5e653]: Add nsf to ↵ | jan.nijtmans | 2016-04-01 | 3 | -4/+5 |
| |\ \ \ \ \ \ \ \ | | | |_|_|_|/ / / | | |/| | | | | | | | | | | | | | | | coffbase.txt. Eliminate exess spacing | ||||
| | * | | | | | | | RFE [0ef5e653ff4caf5f896ec1182e0aac38ab9a0c46|0ef5e653]: Add nsf to coffbase.txt | jan.nijtmans | 2016-04-01 | 1 | -0/+1 |
| | |\ \ \ \ \ \ \ | | | |_|_|_|_|_|/ | | |/| | | | | | | |||||
| | | * | | | | | | RFE [0ef5e653ff4caf5f896ec1182e0aac38ab9a0c46|0ef5e653]: Add nsf to coffbase.txt | jan.nijtmans | 2016-04-01 | 1 | -0/+1 |
| | | | | | | | | | |||||
| | | * | | | | | | (cherry-pick): Better fix for [7d0db7c388f52de81]: In stead of adding ↵ | jan.nijtmans | 2016-03-29 | 1 | -66/+66 |
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | dependencies to multiple Makefile lines, combine them | ||||
| | * | | | | | | | (cherry-pick): Better fix for [7d0db7c388f52de81]: In stead of adding ↵ | jan.nijtmans | 2016-03-29 | 1 | -66/+66 |
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | dependencies to multiple Makefile lines, combine them | ||||
| * | | | | | | | | Two micro-optimizations in Win and UNIX notifier. See: ↵ | jan.nijtmans | 2016-04-01 | 5 | -43/+47 |
| |\ \ \ \ \ \ \ \ | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | [http://code.activestate.com/lists/tcl-core/15645/] | ||||
| | * \ \ \ \ \ \ \ | merge trunk | jan.nijtmans | 2016-03-30 | 14 | -335/+627 |
| | |\ \ \ \ \ \ \ \ | | |/ / / / / / / / | |/| | | | | | | | | |||||
| | * | | | | | | | | - Undo unix notifier changes: too risky at this moment. | jan.nijtmans | 2016-03-25 | 17 | -293/+229 |
| | |\ \ \ \ \ \ \ \ | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | - Merge trunk - (cherry-pick from dhr-micro-optimization): Micro-optimization: remove double checked lock from TclGetAllocCache in favour of initialization in TclInitSubsystems | ||||
| | * | | | | | | | | | (experiment) Use TclpMasterLock() in stead of a separate notifierInitMutex. ↵ | jan.nijtmans | 2016-03-21 | 4 | -19/+54 |
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | One less mutex to be worried about. | ||||
* | | | | | | | | | | | Revise "dict" Tcl_ObjType to use proposed routines. | dgp | 2016-03-30 | 1 | -84/+99 |
| | | | | | | | | | | | |||||
* | | | | | | | | | | | Revise several ACCEPT_NAN stanzas. | dgp | 2016-03-30 | 3 | -29/+61 |
| | | | | | | | | | | | |||||
* | | | | | | | | | | | Remove direct access to Tcl_Obj typePtr field that does nothing of any | dgp | 2016-03-30 | 1 | -10/+4 |
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | obvious benefit. | ||||
* | | | | | | | | | | | merge trunk: | dgp | 2016-03-30 | 4 | -146/+81 |
|\ \ \ \ \ \ \ \ \ \ \ | |/ / / / / / / / / / | |||||
| * | | | | | | | | | | Eliminate AT_FORK_INIT_VALUE/RESET_ATFORK_MUTEX macro's, since other values ↵ | jan.nijtmans | 2016-03-29 | 3 | -80/+15 |
| | |_|_|_|_|_|_|_|/ | |/| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | than the default are not supported anyway. This results in the elimination of (empty functions anyway) AtForkPrepare/AtForkParent. Also improve consistancy in some variable names. No change of functionality. | ||||
| * | | | | | | | | | Better fix for [7d0db7c388f52de81]: In stead of adding dependencies to ↵ | jan.nijtmans | 2016-03-27 | 1 | -66/+66 |
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | multiple Makefile lines, combine them | ||||
* | | | | | | | | | | Functional conversion of "list" Tcl_ObjType to proposed routines. | dgp | 2016-03-29 | 4 | -88/+137 |
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | Not yet completely tidy and finished. |