| Commit message (Collapse) | Author | Age | Files | Lines |
... | |
|\ \ \
| |/ / |
|
| |\ \ |
|
| |\ \ \ |
|
| |\ \ \ \ |
|
| |\ \ \ \ \ |
|
| | | | | | |
| | | | | | |
| | | | | | |
| | | | | | | |
This version <i>almost</i> works, except for a problem with restoring the
context namespace upon return (which produces very strange results!)
|
|\ \ \ \ \ \ \
| | |_|_|_|/ /
| |/| | | | | |
|
| | | | | | | |
|
| |\ \ \ \ \ \ |
|
| | | | | | | |
| | | | | | | |
| | | | | | | |
| | | | | | | | |
to trunk
|
| | | | | | | | |
|
| |\ \ \ \ \ \ \
| | |/ / / / / / |
|
| | | | | | | |
| | | | | | | |
| | | | | | | |
| | | | | | | | |
other means than covering behind void pointers.
|
| | | | | | | |
| | | | | | | |
| | | | | | | |
| | | | | | | | |
the no-indices case; that's the only case anyone actually commonly uses.
|
| | | | | | | | |
|
| | | | | | | | |
|
| |/ / / / / / |
|
| | | | | | |
| | | | | | |
| | | | | | |
| | | | | | | |
smashes the array or its elements flat, This affects traces on env, links to
env, and iterations over env: it makes them work as naïvely expected.
|
| | | | | | |
| | | | | | |
| | | | | | |
| | | | | | | |
pre-resolve command names can choose whether or not TclNREvalObjv() should
attempt to re-do the resolution from objv[0] when something goes wrong.
|
| |\ \ \ \ \ \ |
|
| | | | | | | | |
|
| | | | | | | |
| | | | | | | |
| | | | | | | |
| | | | | | | |
| | | | | | | | |
determine whether the pre-subst source information in a CmdFrame is to
be used. This takes the place of numLevels cross checking, so that field
is removed. Routines are consolidated as well.
|
| | | | | | | |
| | | | | | | |
| | | | | | | |
| | | | | | | | |
source strings from a common routine, with care taken to reduce copying
by that routine.
|
| | | | | | | |
| | | | | | | |
| | | | | | | |
| | | | | | | |
| | | | | | | |
| | | | | | | |
| | | | | | | |
| | | | | | | |
| | | | | | | | |
unreachable by extensions. This checkin removes all the code supporting
that flag value.
The consequence is that all the calls to TclNREvalObjEx() and its callers
that are currently choosing not to pass the TCL_EVAL_DIRECT flag in when
they pass in a non-NULL invoker will no longer be free to change their
mind. That might be reason not to adopt this change.
|
| | | | | | | | |
|
| | | | | | | | |
|
| | | | | | | |
| | | | | | | |
| | | | | | | |
| | | | | | | |
| | | | | | | |
| | | | | | | |
| | | | | | | |
| | | | | | | |
| | | | | | | |
| | | | | | | | |
exist only for the sake of taking great pains to make sure that pure list
values remain pure list values.
The value of pure list values is no longer what it once was. For a long long
time now, any canonical list values have been equally good. This branch
is Work In Progress eliminating the complication of the additional type value.
Currently some minor botches are breaking execution tracing tests.
|
| | | | | | | |
| | | | | | | |
| | | | | | | |
| | | | | | | | |
The pc -> command index mapping function it provided can be achieved using
other data already in the ByteCode struct.
|
| | | | | | | |
| | | | | | | |
| | | | | | | |
| | | | | | | |
| | | | | | | |
| | | | | | | | |
In file included from ./generic/itcl2TclOO.c:12:0:
/Tcl/include/tclInt.h:3012:8: warning: ‘struct addrinfo’ declared inside parameter list [enabled by default]
const char **errorMsgPtr);
^
|
| | | | | | | | |
|
| | | | | | | |
| | | | | | | |
| | | | | | | |
| | | | | | | |
| | | | | | | | |
ClientData, so less type casts are needed in the code.
Disadvantage: somewhat more code duplication, but it makes the code much more understandable.
|
| | | | | | | |
| | | | | | | |
| | | | | | | | |
Fix comment on _ANSI_ARGS_ which is no longer true since 8.6.
|
| | | | | | | |
| | | | | | | |
| | | | | | | |
| | | | | | | | |
platforms it will be aligned to 16 characters anyway.
|
| | | | | | | |
| | | | | | | |
| | | | | | | |
| | | | | | | | |
stub table initialization - previously part of Tcl_InitStubs().
|
| | |\ \ \ \ \ \
| | | | |_|_|_|/
| | | |/| | | | |
|
| | | | | | | | |
|
| | | | | | | |
| | | | | | | |
| | | | | | | |
| | | | | | | | |
(and the complex machinery associated with it) as as it is no longer needed.
|
| | |\ \ \ \ \ \
| | | |/ / / / /
| | | | | | | |
| | | | | | | |
| | | | | | | |
| | | | | | | | |
macros using Tcl_NewIntObj, Tcl_DbNewLongObj and Tcl_SetIntObj.
Starting with Tcl 8.5, this is exactly the same, it only eliminates code duplication.
Eliminate use of NO_WIDE_TYPE everywhere: It's exactly the same as TCL_WIDE_INT_IS_LONG
|
| |/ / / / / /
| | | | | | |
| | | | | | | |
behind invokehidden commands.
|
| |\ \ \ \ \ \
| | |/ / / / / |
|
| | | | | | | |
|
| |\ \ \ \ \ \
| | |/ / / / / |
|
| | | | | | | |
|
| |\ \ \ \ \ \
| | |/ / / / / |
|
| | | | | | | |
|
| | | | | | |
| | | | | | |
| | | | | | |
| | | | | | | |
typePtr->setFromAnyProc (except the call from inside the Tcl_ConvertToType function) from the Tcl core.
|
| |\ \ \ \ \ \
| | |/ / / / / |
|
| | | | | | |
| | | | | | |
| | | | | | |
| | | | | | | |
the same field, but it allows twoPtrValue.ptr2 to be used for other purposes.
|
| | | | | | |
| | | | | | |
| | | | | | | |
machinery, in view of making public some parts of it.
|
| | | | | | |
| | | | | | |
| | | | | | |
| | | | | | | |
rewriting; yieldto also requires one fewer bounce. Mostly from mig-nre-mods
|