summaryrefslogtreecommitdiffstats
path: root/unix/configure.in
diff options
context:
space:
mode:
authordgp <dgp@users.sourceforge.net>2003-10-06 16:59:23 (GMT)
committerdgp <dgp@users.sourceforge.net>2003-10-06 16:59:23 (GMT)
commit45f853f735ec129e4f324d44318f1eb80dcc0cdd (patch)
tree838f0314a811e15257eb0af70b4fb74163de83af /unix/configure.in
parentc2dd6ffabf1f18a3dc4c0f0439cbbbd884ef31a7 (diff)
downloadtk-45f853f735ec129e4f324d44318f1eb80dcc0cdd.zip
tk-45f853f735ec129e4f324d44318f1eb80dcc0cdd.tar.gz
tk-45f853f735ec129e4f324d44318f1eb80dcc0cdd.tar.bz2
*unix/configure.in: Reconfigured to use $TCL_PREFIX as the
default value of --prefix, and also added warning when a TK_PREFIX value different from TCL_PREFIX is selected, since [package require Tk] fails in that configuration. [Bug 765642] * unix/configure: autoconf (2.13)
Diffstat (limited to 'unix/configure.in')
-rw-r--r--unix/configure.in36
1 files changed, 21 insertions, 15 deletions
diff --git a/unix/configure.in b/unix/configure.in
index f5a714a..5ca56d8 100644
--- a/unix/configure.in
+++ b/unix/configure.in
@@ -3,7 +3,7 @@ dnl This file is an input file used by the GNU "autoconf" program to
dnl generate the file "configure", which is run during Tk installation
dnl to configure the system for the local environment.
#
-# RCS: @(#) $Id: configure.in,v 1.83.2.4 2003/10/06 15:27:32 dgp Exp $
+# RCS: @(#) $Id: configure.in,v 1.83.2.5 2003/10/06 16:59:25 dgp Exp $
AC_INIT(../generic/tk.h)
AC_PREREQ(2.13)
@@ -15,12 +15,25 @@ TK_PATCH_LEVEL=".5"
VERSION=${TK_VERSION}
LOCALES="cs de el en en_gb es fr it nl ru"
+#--------------------------------------------------------------------
+# Find and load the tclConfig.sh file
+#--------------------------------------------------------------------
+
+SC_PATH_TCLCONFIG
+SC_LOAD_TCLCONFIG
+
+if test "${TCL_VERSION}" != "${TK_VERSION}"; then
+ AC_MSG_ERROR([${TCL_BIN_DIR}/tclConfig.sh is for Tcl ${TCL_VERSION}.
+Tk ${TK_VERSION}${TK_PATCH_LEVEL} needs Tcl ${TK_VERSION}.
+Use --with-tcl= option to indicate location of tclConfig.sh file for Tcl ${TK_VERSION}.])
+fi
+
#------------------------------------------------------------------------
# Handle the --prefix=... option
#------------------------------------------------------------------------
if test "${prefix}" = "NONE"; then
- prefix=/usr/local
+ prefix="$TCL_PREFIX"
fi
if test "${exec_prefix}" = "NONE"; then
exec_prefix=$prefix
@@ -86,19 +99,6 @@ SC_TCL_EARLY_FLAGS
SC_TCL_64BIT_FLAGS
#--------------------------------------------------------------------
-# Find and load the tclConfig.sh file
-#--------------------------------------------------------------------
-
-SC_PATH_TCLCONFIG
-SC_LOAD_TCLCONFIG
-
-if test "${TCL_VERSION}" != "${TK_VERSION}"; then
- AC_MSG_ERROR([${TCL_BIN_DIR}/tclConfig.sh is for Tcl ${TCL_VERSION}.
-Tk ${TK_VERSION}${TK_PATCH_LEVEL} needs Tcl ${TK_VERSION}.
-Use --with-tcl= option to indicate location of tclConfig.sh file for Tcl ${TK_VERSION}.])
-fi
-
-#--------------------------------------------------------------------
# Recompute the necessary flags to run the compiler
#--------------------------------------------------------------------
@@ -121,6 +121,12 @@ if test "$TCL_EXEC_PREFIX" != "$exec_prefix"; then
LIB_RUNTIME_DIR="${LIB_RUNTIME_DIR}:${TCL_EXEC_PREFIX}/lib"
fi
+if test "$TCL_PREFIX" != "$prefix"; then
+ AC_MSG_WARN([
+ Different --prefix selected for Tk and Tcl!
+ [[package require Tk]] may not work correctly in tclsh.])
+fi
+
#--------------------------------------------------------------------
# On a few very rare systems, all of the libm.a stuff is
# already in libc.a. Set compiler flags accordingly.