summaryrefslogtreecommitdiffstats
path: root/unix/configure.in
diff options
context:
space:
mode:
authordas <das>2007-04-29 02:25:36 (GMT)
committerdas <das>2007-04-29 02:25:36 (GMT)
commitd1da82b0a87023ad752173dda374a0656228af58 (patch)
treee0eae405a5eb0121715cb86e8df7aa229a7cb2de /unix/configure.in
parent1a476a1767db9dd2a37ed65dbe0cd3a24413d4b4 (diff)
downloadtk-d1da82b0a87023ad752173dda374a0656228af58.zip
tk-d1da82b0a87023ad752173dda374a0656228af58.tar.gz
tk-d1da82b0a87023ad752173dda374a0656228af58.tar.bz2
* unix/Makefile.in (dist): copy license.terms to dist macosx dir.
* unix/configure.in: install license.terms into Tk.framework; fix tk debug build detection. * unix/configure: autoconf-2.13
Diffstat (limited to 'unix/configure.in')
-rw-r--r--unix/configure.in5
1 files changed, 3 insertions, 2 deletions
diff --git a/unix/configure.in b/unix/configure.in
index c1a6911..37c2c33 100644
--- a/unix/configure.in
+++ b/unix/configure.in
@@ -3,7 +3,7 @@ dnl This file is an input file used by the GNU "autoconf" program to
dnl generate the file "configure", which is run during Tk installation
dnl to configure the system for the local environment.
#
-# RCS: @(#) $Id: configure.in,v 1.83.2.37 2007/02/04 02:51:58 das Exp $
+# RCS: @(#) $Id: configure.in,v 1.83.2.38 2007/04/29 02:25:36 das Exp $
AC_INIT(../generic/tk.h)
AC_PREREQ(2.13)
@@ -265,7 +265,7 @@ if test $tk_aqua = yes; then
LIBS="$LIBS -framework Carbon"
CFLAGS="$CFLAGS -fpascal-strings"
TK_WINDOWINGSYSTEM=AQUA
- if test "${enable_symbols}" = yes; then
+ if test -n "${enable_symbols}" -a "${enable_symbols}" != no; then
AC_DEFINE(TK_MAC_DEBUG, 1, [Are TkAqua debug messages enabled?])
fi
else
@@ -454,6 +454,7 @@ if test "$FRAMEWORK_BUILD" = "1" ; then
EXTRA_INSTALL="install-private-headers html-tk"
EXTRA_BUILD_HTML='@ln -fs contents.htm $(HTML_INSTALL_DIR)/TkTOC.html'
EXTRA_INSTALL_BINARIES='@echo "Installing Info.plist to $(LIB_INSTALL_DIR)/Resources" && mkdir -p "$(LIB_INSTALL_DIR)/Resources" && $(INSTALL_DATA) Tk-Info.plist "$(LIB_INSTALL_DIR)/Resources/Info.plist"'
+ EXTRA_INSTALL_BINARIES="$EXTRA_INSTALL_BINARIES"' && echo "Installing license.terms to $(LIB_INSTALL_DIR)/Resources" && $(INSTALL_DATA) "$(TOP_DIR)/license.terms" "$(LIB_INSTALL_DIR)/Resources"'
if test $tk_aqua = yes; then
EXTRA_INSTALL_BINARIES="$EXTRA_INSTALL_BINARIES"' && echo "Installing ${TK_RSRC_FILE} to $(LIB_INSTALL_DIR)/Resources" && mkdir -p "$(LIB_INSTALL_DIR)/Resources" && $(INSTALL_DATA) "${TK_RSRC_FILE}" "$(LIB_INSTALL_DIR)/Resources"'
EXTRA_INSTALL_BINARIES="$EXTRA_INSTALL_BINARIES"' && echo "Installing wish$(VERSION) script to $(INSTALL_ROOT)/'"${bindir}"'" && mkdir -p "$(INSTALL_ROOT)/'"${bindir}"'" && printf > "$(INSTALL_ROOT)/'"${bindir}"'/wish$(VERSION)" "#!/bin/sh\n\"\$$(dirname \$$0)'"`eval d="${bindir}"; echo "$d" | sed -e 's#/[^/][^/]*#/..#g'`"'$(bindir)/Wish\" \"\$$@\"" && chmod +x "$(INSTALL_ROOT)/'"${bindir}"'/wish$(VERSION)"'