summaryrefslogtreecommitdiffstats
path: root/unix/configure.in
diff options
context:
space:
mode:
authordas <das>2007-06-06 09:56:21 (GMT)
committerdas <das>2007-06-06 09:56:21 (GMT)
commit14f8f936349132e0f6dc66230d2378d47d0968d7 (patch)
treec96ad93c0754828a47900e5775a093a7adfd5a7b /unix/configure.in
parent09ebf8db9ad77a1c0548875d503e3dd78ee3a462 (diff)
downloadtk-14f8f936349132e0f6dc66230d2378d47d0968d7.zip
tk-14f8f936349132e0f6dc66230d2378d47d0968d7.tar.gz
tk-14f8f936349132e0f6dc66230d2378d47d0968d7.tar.bz2
* unix/configure.in (Darwin): link the Tk and Wish plists into their
binaries in all cases; fix 64bit arch removal in fat 32&64bit builds. * unix/tcl.m4 (Darwin): fix CF checks in fat 32&64bit builds. * unix/configure: autoconf-2.13
Diffstat (limited to 'unix/configure.in')
-rw-r--r--unix/configure.in16
1 files changed, 8 insertions, 8 deletions
diff --git a/unix/configure.in b/unix/configure.in
index 6c8ac92..56b5d82 100644
--- a/unix/configure.in
+++ b/unix/configure.in
@@ -3,7 +3,7 @@ dnl This file is an input file used by the GNU "autoconf" program to
dnl generate the file "configure", which is run during Tk installation
dnl to configure the system for the local environment.
#
-# RCS: @(#) $Id: configure.in,v 1.83.2.39 2007/05/30 14:06:21 dgp Exp $
+# RCS: @(#) $Id: configure.in,v 1.83.2.40 2007/06/06 09:56:22 das Exp $
AC_INIT(../generic/tk.h)
AC_PREREQ(2.13)
@@ -252,10 +252,10 @@ if test "`uname -s`" = "Darwin" ; then
fi
fi
AC_MSG_RESULT([$tk_aqua])
- # remove 64-bit arch flags from CFLAGS for combined 32-bit and 64-bit fat
+ # remove 64-bit arch flags from CFLAGS et al. for combined 32 & 64 bit fat
# builds, as neither TkAqua nor TkX11 can be built for 64-bit at present.
- test "$fat_32_64" = yes && \
- CFLAGS="`echo "$CFLAGS " | sed -e 's/-arch ppc64 / /g' -e 's/-arch x86_64 / /g'`"
+ test "$fat_32_64" = yes && for v in CFLAGS CPPFLAGS LDFLAGS; do
+ eval $v'="`echo "$'$v' "|sed -e "s/-arch ppc64 / /g" -e "s/-arch x86_64 / /g"`"'; done
else
tk_aqua=no
fi
@@ -418,11 +418,13 @@ if test "`uname -s`" = "Darwin" ; then
SC_ENABLE_FRAMEWORK
TK_SHLIB_LD_EXTRAS="-compatibility_version ${TK_VERSION} -current_version ${TK_VERSION}`echo ${TK_PATCH_LEVEL} | awk ['{match($0, "\\\.[0-9]+"); print substr($0,RSTART,RLENGTH)}']`"
TK_SHLIB_LD_EXTRAS="${TK_SHLIB_LD_EXTRAS}"' -install_name ${DYLIB_INSTALL_DIR}/${TK_LIB_FILE} -seg1addr 0xb000000 -unexported_symbols_list $$(f=$(TCL_STUB_LIB_FILE).E && nm -gjp $(TCL_BIN_DIR)/$(TCL_STUB_LIB_FILE) | grep ^_[[^_]] > $$f && echo $$f)'
+ TK_SHLIB_LD_EXTRAS="${TK_SHLIB_LD_EXTRAS}"' -sectcreate __TEXT __info_plist Tk-Info.plist'
+ EXTRA_WISH_LIBS='-sectcreate __TEXT __info_plist Wish-Info.plist'
+ tk_config_files="${tk_config_files} [Tk-Info.plist:../macosx/Tk-Info.plist.in Wish-Info.plist:../macosx/Wish-Info.plist.in]"
fi
if test "$FRAMEWORK_BUILD" = "1" ; then
AC_DEFINE(TK_FRAMEWORK)
- tk_config_files="${tk_config_files} [Tk-Info.plist:../macosx/Tk-Info.plist.in]"
# Construct a fake local framework structure to make linking with
# '-framework Tk' and running of tktest work
AC_OUTPUT_COMMANDS([test "$FRAMEWORK_BUILD" = "1" && n=Tk &&
@@ -497,8 +499,6 @@ fi
# Support for building the Aqua resource files
if test $tk_aqua = yes; then
- tk_config_files="${tk_config_files} [Wish-Info.plist:../macosx/Wish-Info.plist.in]"
- EXTRA_WISH_LIBS='-sectcreate __TEXT __info_plist Wish-Info.plist'
LIB_RSRC_FILE='${TK_RSRC_FILE}'
APP_RSRC_FILE='${WISH_RSRC_FILE}'
REZ=/Developer/Tools/Rez
@@ -507,7 +507,7 @@ if test $tk_aqua = yes; then
EXTRA_INSTALL_BINARIES='@echo "Installing $(TK_RSRC_FILE) to $(LIB_INSTALL_DIR)" && $(INSTALL_DATA) $(TK_RSRC_FILE) $(LIB_INSTALL_DIR)'
TK_BUILD_LIB_SPEC="$TK_BUILD_LIB_SPEC -sectcreate __TEXT __tk_rsrc `pwd`/\${TK_RSRC_FILE}"
TK_LIB_SPEC="$TK_LIB_SPEC -sectcreate __TEXT __tk_rsrc ${libdir}/\${TK_RSRC_FILE}"
- elif test "$FRAMEWORK_BUILD" = "0"; then
+ else
TK_SHLIB_LD_EXTRAS="$TK_SHLIB_LD_EXTRAS -sectcreate __TEXT __tk_rsrc \${TK_RSRC_FILE}"
fi
fi