summaryrefslogtreecommitdiffstats
path: root/unix/configure.in
diff options
context:
space:
mode:
authormdejong <mdejong>2001-06-22 23:59:48 (GMT)
committermdejong <mdejong>2001-06-22 23:59:48 (GMT)
commit653dd70d1e0efe8e90b7e8e44f7b1823d5bc0add (patch)
treecb63c3adf3794d0d743e2a9d1852748190d231b8 /unix/configure.in
parent83ca1ca9b40094b453deb82faa202aa2d9fb7a03 (diff)
downloadtk-653dd70d1e0efe8e90b7e8e44f7b1823d5bc0add.zip
tk-653dd70d1e0efe8e90b7e8e44f7b1823d5bc0add.tar.gz
tk-653dd70d1e0efe8e90b7e8e44f7b1823d5bc0add.tar.bz2
* unix/Makefile.in: Set CFLAGS to @CFLAGS@ and @CFLAGS_DEFAULT@.
Set LDFLAGS to @LDFLAGS@ and @LDFLAGS_DEFAULT@. Add LDFLAGS_DEBUG and LDFLAGS_OPTIMIZE to match the way CFLAGS_DEFAULT works. Use new LDFLAGS variable in the Makefile instead of @LDFLAGS@. * unix/configure: Regen. * unix/configure.in: Don't set CFLAGS to CFLAGS_DEFAULT, instead subst CFLAGS_DEFAULT into the Makefile. Add AC_SUBST for CFLAGS_DEBUG, CFLAGS_OPTIMIZE, LDFLAGS_DEFAULT, LDFLAGS_DEBUG, and LDFLAGS_OPTIMIZE. Remove unused LD_FLAGS subst. * unix/tcl.m4: Update from Tcl. * win/Makefile.in: Set CFLAGS to @CFLAGS@ and @CFLAGS_DEFAULT@. Set LDFLAGS to @LDFLAGS@ and @LDFLAGS_DEFAULT@. * win/configure: Regen. * win/configure.in: Don't set CFLAGS or LDFLAGS, instead subst CFLAGS_DEFAULT and LDFLAGS_DEFAULT into the Makefile. * win/tcl.m4: Update from Tcl.
Diffstat (limited to 'unix/configure.in')
-rw-r--r--unix/configure.in9
1 files changed, 6 insertions, 3 deletions
diff --git a/unix/configure.in b/unix/configure.in
index 7ca3fe1..1745a75 100644
--- a/unix/configure.in
+++ b/unix/configure.in
@@ -3,7 +3,7 @@ dnl This file is an input file used by the GNU "autoconf" program to
dnl generate the file "configure", which is run during Tk installation
dnl to configure the system for the local environment.
AC_INIT(../generic/tk.h)
-# RCS: @(#) $Id: configure.in,v 1.58 2001/04/25 21:51:06 mdejong Exp $
+# RCS: @(#) $Id: configure.in,v 1.59 2001/06/22 23:59:48 mdejong Exp $
TK_VERSION=8.4
TK_MAJOR_VERSION=8
@@ -71,7 +71,6 @@ SC_ENABLE_SYMBOLS
LIB_RUNTIME_DIR='${LIB_RUNTIME_DIR}'
-CFLAGS=${CFLAGS_DEFAULT}
TK_DBGX=${DBGX}
#------------------------------------------------------------------------
@@ -417,10 +416,14 @@ AC_SUBST(TK_BUILD_EXP_FILE)
AC_SUBST(TK_EXP_FILE)
AC_SUBST(CFLAGS_DEFAULT)
+AC_SUBST(CFLAGS_DEBUG)
+AC_SUBST(CFLAGS_OPTIMIZE)
+AC_SUBST(LDFLAGS_DEFAULT)
+AC_SUBST(LDFLAGS_DEBUG)
+AC_SUBST(LDFLAGS_OPTIMIZE)
AC_SUBST(TK_DBGX)
AC_SUBST(DL_LIBS)
AC_SUBST(EXTRA_CFLAGS)
-AC_SUBST(LD_FLAGS)
AC_SUBST(MATH_LIBS)
AC_SUBST(MAKE_LIB)
AC_SUBST(SHLIB_CFLAGS)