summaryrefslogtreecommitdiffstats
path: root/unix/configure.in
diff options
context:
space:
mode:
authordas <das>2007-08-07 05:07:20 (GMT)
committerdas <das>2007-08-07 05:07:20 (GMT)
commit1c39836a50a95c7d74cb8243f19777e92add6ca2 (patch)
treed03f5f3dbb00ee1f7ff7a348bc087e610cc9348b /unix/configure.in
parente6b3b1777638434f20719699fb170d21545c38a7 (diff)
downloadtk-1c39836a50a95c7d74cb8243f19777e92add6ca2.zip
tk-1c39836a50a95c7d74cb8243f19777e92add6ca2.tar.gz
tk-1c39836a50a95c7d74cb8243f19777e92add6ca2.tar.bz2
* unix/Makefile.in: add support for compile flags specific to
object files linked directly into executables. * unix/configure.in (Darwin): only use -seg1addr flag when prebinding; use -mdynamic-no-pic flag for object files linked directly into exes. * unix/configure: autoconf-2.59
Diffstat (limited to 'unix/configure.in')
-rw-r--r--unix/configure.in7
1 files changed, 5 insertions, 2 deletions
diff --git a/unix/configure.in b/unix/configure.in
index cb9e2c6..a609d5d 100644
--- a/unix/configure.in
+++ b/unix/configure.in
@@ -3,7 +3,7 @@ dnl This file is an input file used by the GNU "autoconf" program to
dnl generate the file "configure", which is run during Tk installation
dnl to configure the system for the local environment.
#
-# RCS: @(#) $Id: configure.in,v 1.136 2007/06/29 03:18:34 das Exp $
+# RCS: @(#) $Id: configure.in,v 1.137 2007/08/07 05:07:21 das Exp $
AC_INIT([tk],[8.5])
AC_PREREQ(2.59)
@@ -529,10 +529,12 @@ WISH_RSRC_FILE='wish$(VERSION).rsrc'
if test "`uname -s`" = "Darwin" ; then
SC_ENABLE_FRAMEWORK
TK_SHLIB_LD_EXTRAS="-compatibility_version ${TK_VERSION} -current_version ${TK_VERSION}`echo ${TK_PATCH_LEVEL} | awk ['{match($0, "\\\.[0-9]+"); print substr($0,RSTART,RLENGTH)}']`"
- TK_SHLIB_LD_EXTRAS="${TK_SHLIB_LD_EXTRAS}"' -install_name ${DYLIB_INSTALL_DIR}/${TK_LIB_FILE} -seg1addr 0xb000000 -unexported_symbols_list $$(f=$(TCL_STUB_LIB_FILE).E && nm -gjp $(TCL_BIN_DIR)/$(TCL_STUB_LIB_FILE) | grep ^_[[^_]] > $$f && echo $$f)'
+ TK_SHLIB_LD_EXTRAS="${TK_SHLIB_LD_EXTRAS}"' -install_name ${DYLIB_INSTALL_DIR}/${TK_LIB_FILE} -unexported_symbols_list $$(f=$(TCL_STUB_LIB_FILE).E && nm -gjp $(TCL_BIN_DIR)/$(TCL_STUB_LIB_FILE) | grep ^_[[^_]] > $$f && echo $$f)'
+ echo "$LDFLAGS " | grep -q -- '-prebind ' && TK_SHLIB_LD_EXTRAS="${TK_SHLIB_LD_EXTRAS}"' -seg1addr 0xb000000'
TK_SHLIB_LD_EXTRAS="${TK_SHLIB_LD_EXTRAS}"' -sectcreate __TEXT __info_plist Tk-Info.plist'
EXTRA_WISH_LIBS='-sectcreate __TEXT __info_plist Wish-Info.plist'
AC_CONFIG_FILES([Tk-Info.plist:../macosx/Tk-Info.plist.in Wish-Info.plist:../macosx/Wish-Info.plist.in])
+ EXTRA_APP_CC_SWITCHES='-mdynamic-no-pic'
fi
if test "$FRAMEWORK_BUILD" = "1" ; then
@@ -690,6 +692,7 @@ AC_SUBST(PRIVATE_INCLUDE_DIR)
AC_SUBST(HTML_DIR)
AC_SUBST(EXTRA_CC_SWITCHES)
+AC_SUBST(EXTRA_APP_CC_SWITCHES)
AC_SUBST(EXTRA_INSTALL)
AC_SUBST(EXTRA_INSTALL_BINARIES)
AC_SUBST(EXTRA_BUILD_HTML)