summaryrefslogtreecommitdiffstats
path: root/unix/configure.in
diff options
context:
space:
mode:
authorhobbs <hobbs>2003-11-12 01:10:40 (GMT)
committerhobbs <hobbs>2003-11-12 01:10:40 (GMT)
commit0faab4b1fcb34df789147ece61ade73b3b7e5b67 (patch)
tree83c44648b67ec2f54455378ed967bf0a4443d295 /unix/configure.in
parent459cac7ed25678462be3072d2b7047b512d49a4c (diff)
downloadtk-0faab4b1fcb34df789147ece61ade73b3b7e5b67.zip
tk-0faab4b1fcb34df789147ece61ade73b3b7e5b67.tar.gz
tk-0faab4b1fcb34df789147ece61ade73b3b7e5b67.tar.bz2
* unix/configure:
* unix/configure.in: use xft-config instead of pkg-config to determine xft info. * unix/tcl.m4: improve AIX --enable-64bit handling remove -D__NO_STRING_INLINES -D__NO_MATH_INLINES from CFLAGS_OPTIMIZE on Linux. Make default opt -O2 (was -O).
Diffstat (limited to 'unix/configure.in')
-rw-r--r--unix/configure.in6
1 files changed, 3 insertions, 3 deletions
diff --git a/unix/configure.in b/unix/configure.in
index 723cd4e..8861f3f 100644
--- a/unix/configure.in
+++ b/unix/configure.in
@@ -3,7 +3,7 @@ dnl This file is an input file used by the GNU "autoconf" program to
dnl generate the file "configure", which is run during Tk installation
dnl to configure the system for the local environment.
#
-# RCS: @(#) $Id: configure.in,v 1.91 2003/10/06 17:11:31 dgp Exp $
+# RCS: @(#) $Id: configure.in,v 1.92 2003/11/12 01:10:40 hobbs Exp $
AC_INIT(../generic/tk.h)
AC_PREREQ(2.57)
@@ -306,8 +306,8 @@ XFT_CFLAGS=""
XFT_LIBS=""
if test "$enable_xft" = "yes" ; then
AC_MSG_CHECKING([for xft configuration])
- XFT_CFLAGS=`pkg-config --cflags xft` || enable_xft="no"
- XFT_LIBS=`pkg-config --libs xft` || enable_xft="no"
+ XFT_CFLAGS=`xft-config --cflags` || enable_xft="no"
+ XFT_LIBS=`xft-config --libs` || enable_xft="no"
if test "$enable_xft" = "yes" ; then
AC_MSG_RESULT([ok])
else