summaryrefslogtreecommitdiffstats
path: root/unix/configure.in
diff options
context:
space:
mode:
authorhobbs <hobbs>2005-05-07 00:28:13 (GMT)
committerhobbs <hobbs>2005-05-07 00:28:13 (GMT)
commit7c1ded63bed472840c34fd71f6d4e144b62ae453 (patch)
treed17b457b8dea7b3eacf2ddc8bfa3c52d7c0c7cc5 /unix/configure.in
parent1f27bcb487508323c68e02927575ef9717428b9c (diff)
downloadtk-7c1ded63bed472840c34fd71f6d4e144b62ae453.zip
tk-7c1ded63bed472840c34fd71f6d4e144b62ae453.tar.gz
tk-7c1ded63bed472840c34fd71f6d4e144b62ae453.tar.bz2
* unix/configure: regen
* unix/configure.in: add AC_C_BIGENDIAN check and pkg-config xft checks to extend xft search. * unix/tcl.m4: correct Solaris 10 (5.10) check and add support for x86_64 Solaris cc builds.
Diffstat (limited to 'unix/configure.in')
-rw-r--r--unix/configure.in16
1 files changed, 13 insertions, 3 deletions
diff --git a/unix/configure.in b/unix/configure.in
index 3c06656..6b9f99e 100644
--- a/unix/configure.in
+++ b/unix/configure.in
@@ -3,7 +3,7 @@ dnl This file is an input file used by the GNU "autoconf" program to
dnl generate the file "configure", which is run during Tk installation
dnl to configure the system for the local environment.
#
-# RCS: @(#) $Id: configure.in,v 1.99 2005/01/10 18:57:41 jenglish Exp $
+# RCS: @(#) $Id: configure.in,v 1.100 2005/05/07 00:28:17 hobbs Exp $
AC_INIT([tk],[8.5])
AC_PREREQ(2.57)
@@ -109,6 +109,12 @@ SC_TCL_EARLY_FLAGS
SC_TCL_64BIT_FLAGS
+#--------------------------------------------------------------------
+# Check endianness because we can optimize some operations
+#--------------------------------------------------------------------
+
+AC_C_BIGENDIAN
+
#------------------------------------------------------------------------
# If Tcl and Tk are installed in different places, adjust the library
# search path to reflect this.
@@ -295,8 +301,12 @@ XFT_CFLAGS=""
XFT_LIBS=""
if test "$enable_xft" = "yes" ; then
AC_MSG_CHECKING([for xft configuration])
- XFT_CFLAGS=`xft-config --cflags` || enable_xft="no"
- XFT_LIBS=`xft-config --libs` || enable_xft="no"
+ XFT_CFLAGS=`xft-config --cflags 2>/dev/null` || enable_xft="no"
+ XFT_LIBS=`xft-config --libs 2>/dev/null` || enable_xft="no"
+ if test "$enable_xft" = "no" ; then
+ XFT_CFLAGS=`pkg-config --cflags xft 2>/dev/null` || enable_xft="no"
+ XFT_LIBS=`pkg-config --libs xft 2>/dev/null` || enable_xft="no"
+ fi
if test "$enable_xft" = "yes" ; then
AC_MSG_RESULT([ok])
else