summaryrefslogtreecommitdiffstats
path: root/unix/configure.in
diff options
context:
space:
mode:
authorjan.nijtmans <nijtmans@users.sourceforge.net>2013-05-24 12:29:23 (GMT)
committerjan.nijtmans <nijtmans@users.sourceforge.net>2013-05-24 12:29:23 (GMT)
commitc0b4e45ffd661b4211d91f8842bfe94e913e9adc (patch)
treefdaecf6d15222086c86feb03e61fc8fa8fb2d7d0 /unix/configure.in
parent8c8d8e51384939bc47c12e375ba040d1717a2f76 (diff)
downloadtk-c0b4e45ffd661b4211d91f8842bfe94e913e9adc.zip
tk-c0b4e45ffd661b4211d91f8842bfe94e913e9adc.tar.gz
tk-c0b4e45ffd661b4211d91f8842bfe94e913e9adc.tar.bz2
Disable XInitThreads() call until we have a better test for it.
Diffstat (limited to 'unix/configure.in')
-rw-r--r--unix/configure.in8
1 files changed, 5 insertions, 3 deletions
diff --git a/unix/configure.in b/unix/configure.in
index bc22472..7339983 100644
--- a/unix/configure.in
+++ b/unix/configure.in
@@ -592,7 +592,7 @@ fi
# Check whether XKeycodeToKeysym is deprecated in X11 headers.
#--------------------------------------------------------------------
-if test $tk_aqua = no; then
+if test $tk_aqua = no && test "$GCC" = yes; then
AC_MSG_CHECKING([whether XKeycodeToKeysym is deprecated])
tk_oldCFlags=$CFLAGS
CFLAGS="$CFLAGS -Werror"
@@ -601,9 +601,11 @@ if test $tk_aqua = no; then
], [
XKeycodeToKeysym(0,0,0);
], [
- AC_MSG_RESULT([yes])
+ AC_MSG_RESULT([no])
+ ], [
+ AC_MSG_RESULT([yes])
AC_DEFINE(XKEYCODETOKEYSYM_IS_DEPRECATED, 1, [Is XKeycodeToKeysym deprecated?])
- ], AC_MSG_RESULT([no]))
+ ])
CFLAGS=$tk_oldCFlags
fi