summaryrefslogtreecommitdiffstats
path: root/unix/configure.in
diff options
context:
space:
mode:
authordgp <dgp@users.sourceforge.net>2003-10-06 15:27:31 (GMT)
committerdgp <dgp@users.sourceforge.net>2003-10-06 15:27:31 (GMT)
commitc2fb1be822c7ca6b052ea2934a05bbf13461ef91 (patch)
treec15313f5be313dcd5df20ecc5c82ef092aca9df5 /unix/configure.in
parentacfbb6ac86830513ec37ce001e991a8264abc53a (diff)
downloadtk-c2fb1be822c7ca6b052ea2934a05bbf13461ef91.zip
tk-c2fb1be822c7ca6b052ea2934a05bbf13461ef91.tar.gz
tk-c2fb1be822c7ca6b052ea2934a05bbf13461ef91.tar.bz2
* unix/configure.in: Added check that version of Tcl header found
by configure matches that of the Tk we wish to build. As long as the Tk sources insist on lockstep releases, Tk's configuration should verify that's what we have. [Bug 749088] * unix/configure: autoconf (2.13)
Diffstat (limited to 'unix/configure.in')
-rw-r--r--unix/configure.in8
1 files changed, 7 insertions, 1 deletions
diff --git a/unix/configure.in b/unix/configure.in
index 5b4a199..f5a714a 100644
--- a/unix/configure.in
+++ b/unix/configure.in
@@ -3,7 +3,7 @@ dnl This file is an input file used by the GNU "autoconf" program to
dnl generate the file "configure", which is run during Tk installation
dnl to configure the system for the local environment.
#
-# RCS: @(#) $Id: configure.in,v 1.83.2.3 2003/10/03 16:32:39 dgp Exp $
+# RCS: @(#) $Id: configure.in,v 1.83.2.4 2003/10/06 15:27:32 dgp Exp $
AC_INIT(../generic/tk.h)
AC_PREREQ(2.13)
@@ -92,6 +92,12 @@ SC_TCL_64BIT_FLAGS
SC_PATH_TCLCONFIG
SC_LOAD_TCLCONFIG
+if test "${TCL_VERSION}" != "${TK_VERSION}"; then
+ AC_MSG_ERROR([${TCL_BIN_DIR}/tclConfig.sh is for Tcl ${TCL_VERSION}.
+Tk ${TK_VERSION}${TK_PATCH_LEVEL} needs Tcl ${TK_VERSION}.
+Use --with-tcl= option to indicate location of tclConfig.sh file for Tcl ${TK_VERSION}.])
+fi
+
#--------------------------------------------------------------------
# Recompute the necessary flags to run the compiler
#--------------------------------------------------------------------