summaryrefslogtreecommitdiffstats
path: root/unix/configure.in
diff options
context:
space:
mode:
authorjan.nijtmans <nijtmans@users.sourceforge.net>2020-02-14 11:19:25 (GMT)
committerjan.nijtmans <nijtmans@users.sourceforge.net>2020-02-14 11:19:25 (GMT)
commit36415dc8c7cf46b9091ebe18c50fa21d99b1aa70 (patch)
tree33d654577197c15fb5bc93826582bc0f64219f81 /unix/configure.in
parent4b862ee84b334c880bd9109297409fa467eb15f8 (diff)
downloadtk-36415dc8c7cf46b9091ebe18c50fa21d99b1aa70.zip
tk-36415dc8c7cf46b9091ebe18c50fa21d99b1aa70.tar.gz
tk-36415dc8c7cf46b9091ebe18c50fa21d99b1aa70.tar.bz2
Fix travis build. Revise usage of TCLDIR.
Make Tk 8.5 compile/run with Tcl 8.6. Useful for Travis build.
Diffstat (limited to 'unix/configure.in')
-rw-r--r--unix/configure.in11
1 files changed, 7 insertions, 4 deletions
diff --git a/unix/configure.in b/unix/configure.in
index 4b1f992..32cfb02 100644
--- a/unix/configure.in
+++ b/unix/configure.in
@@ -36,10 +36,13 @@ LOCALES="cs da de el en en_gb eo es fr hu it nl pl pt ru sv"
SC_PATH_TCLCONFIG
SC_LOAD_TCLCONFIG
-if test "${TCL_VERSION}" != "${TK_VERSION}"; then
- AC_MSG_ERROR([${TCL_BIN_DIR}/tclConfig.sh is for Tcl ${TCL_VERSION}.
-Tk ${TK_VERSION}${TK_PATCH_LEVEL} needs Tcl ${TK_VERSION}.
-Use --with-tcl= option to indicate location of tclConfig.sh file for Tcl ${TK_VERSION}.])
+if test "${TCL_MAJOR_VERSION}" -ne 8 ; then
+ AC_MSG_ERROR([${PACKAGE_NAME} ${PACKAGE_VERSION} requires Tcl 8.5+
+Found config for Tcl ${TCL_VERSION}])
+fi
+if test "${TCL_MINOR_VERSION}" -lt 5 ; then
+ AC_MSG_ERROR([${PACKAGE_NAME} ${PACKAGE_VERSION} requires Tcl 8.5+
+Found config for Tcl ${TCL_VERSION}])
fi
SC_PROG_TCLSH