summaryrefslogtreecommitdiffstats
path: root/unix/configure.in
diff options
context:
space:
mode:
authorjan.nijtmans <nijtmans@users.sourceforge.net>2013-06-14 10:36:30 (GMT)
committerjan.nijtmans <nijtmans@users.sourceforge.net>2013-06-14 10:36:30 (GMT)
commit1cc38f61d82c48e7cf260b036014ef8fc95b4ea8 (patch)
tree31b65718f7e34f797477c5381d974b8c5fc0a07c /unix/configure.in
parent11de058a4717e03beee74ce580ca7dd05f6423ad (diff)
parent8cc6c4742d9cdc926d336c1335a5438f0877d4cf (diff)
downloadtk-1cc38f61d82c48e7cf260b036014ef8fc95b4ea8.zip
tk-1cc38f61d82c48e7cf260b036014ef8fc95b4ea8.tar.gz
tk-1cc38f61d82c48e7cf260b036014ef8fc95b4ea8.tar.bz2
Static Cygwin wish.exe cannot link with win32's static libtk86.a (because it expects a different runtime), so configure shouldn't even try to do this.
(On a dynamic wish.exe this works, this is exactly how wish can run even without X11). Don't use deprecated stricmp/strnicmp any more, but underscored variant for non-GNU compilers.
Diffstat (limited to 'unix/configure.in')
-rw-r--r--unix/configure.in13
1 files changed, 7 insertions, 6 deletions
diff --git a/unix/configure.in b/unix/configure.in
index a29600c..bf82808 100644
--- a/unix/configure.in
+++ b/unix/configure.in
@@ -745,14 +745,15 @@ else
fi
# libdir must be a fully qualified path and not ${exec_prefix}/lib
eval libdir="$libdir"
- if test "${ac_cv_cygwin}" != "yes" -a "${TCL_LIB_VERSIONS_OK}" = "ok"; then
- TK_LIB_FLAG="-ltk${TK_VERSION}"
- else
- TK_LIB_FLAG="-ltk`echo ${TK_VERSION} | tr -d .`"
- fi
if test "${ac_cv_cygwin}" = "yes" -a "$SHARED_BUILD" = "1"; then
- TK_BUILD_LIB_SPEC="-L\$(TOP_DIR)/win -ltk${TK_MAJOR_VERSION}${TK_MINOR_VERSION} \${TCL_LIB_SPEC}"
+ TK_LIB_FLAG="-ltk`echo ${TK_VERSION} | tr -d .`"
+ TK_BUILD_LIB_SPEC="-L\$(TOP_DIR)/win ${TK_LIB_FLAG}"
else
+ if test "${TCL_LIB_VERSIONS_OK}" = "ok"; then
+ TK_LIB_FLAG="-ltk${TK_VERSION}"
+ else
+ TK_LIB_FLAG="-ltk`echo ${TK_VERSION} | tr -d .`"
+ fi
TK_BUILD_LIB_SPEC="-L`pwd | sed -e 's/ /\\\\ /g'` ${TK_LIB_FLAG}"
fi
TK_LIB_SPEC="-L${libdir} ${TK_LIB_FLAG}"