summaryrefslogtreecommitdiffstats
path: root/unix/configure.in
diff options
context:
space:
mode:
authordas <das>2006-03-22 00:22:05 (GMT)
committerdas <das>2006-03-22 00:22:05 (GMT)
commit2e401c6ee977b437ee39d52471a51d8790212951 (patch)
tree1df5f2360c507dae06487b6d8c965f8a85227d87 /unix/configure.in
parent6fc882c0064facc4bcd4b054d33fa9c33969758a (diff)
downloadtk-2e401c6ee977b437ee39d52471a51d8790212951.zip
tk-2e401c6ee977b437ee39d52471a51d8790212951.tar.gz
tk-2e401c6ee977b437ee39d52471a51d8790212951.tar.bz2
* unix/configure.in: fix detection of symbols build when enabling
TkAqua debug code; filter nm output of libtclstub better to avoid error on intel macs [Bug 1415789]. * unix/configure: autoconf-2.13
Diffstat (limited to 'unix/configure.in')
-rw-r--r--unix/configure.in6
1 files changed, 3 insertions, 3 deletions
diff --git a/unix/configure.in b/unix/configure.in
index 9dd367d..83161a9 100644
--- a/unix/configure.in
+++ b/unix/configure.in
@@ -3,7 +3,7 @@ dnl This file is an input file used by the GNU "autoconf" program to
dnl generate the file "configure", which is run during Tk installation
dnl to configure the system for the local environment.
#
-# RCS: @(#) $Id: configure.in,v 1.83.2.30 2006/03/16 14:01:28 dkf Exp $
+# RCS: @(#) $Id: configure.in,v 1.83.2.31 2006/03/22 00:22:09 das Exp $
AC_INIT(../generic/tk.h)
AC_PREREQ(2.13)
@@ -260,7 +260,7 @@ if test $tk_aqua = yes; then
LIBS="$LIBS -framework Carbon"
CFLAGS="$CFLAGS -fpascal-strings"
TK_WINDOWINGSYSTEM=AQUA
- if test "${enable_symbols+set}" = set; then
+ if test "${enable_symbols}" = yes; then
AC_DEFINE(TK_MAC_DEBUG, 1, [Are TkAqua debug messages enabled?])
fi
else
@@ -412,7 +412,7 @@ WISH_RSRC_FILE='wish$(VERSION).rsrc'
if test "`uname -s`" = "Darwin" ; then
SC_ENABLE_FRAMEWORK
TK_SHLIB_LD_EXTRAS="-compatibility_version ${TK_VERSION} -current_version ${TK_VERSION}`echo ${TK_PATCH_LEVEL} | awk ['{match($0, "\\\.[0-9]+"); print substr($0,RSTART,RLENGTH)}']`"
- TK_SHLIB_LD_EXTRAS="${TK_SHLIB_LD_EXTRAS}"' -install_name ${DYLIB_INSTALL_DIR}/${TK_LIB_FILE} -seg1addr 0xb000000 -unexported_symbols_list $$(f=$(TCL_STUB_LIB_FILE).E && nm -gjp $(TCL_BIN_DIR)/$(TCL_STUB_LIB_FILE) | grep ^_ > $$f && echo $$f)'
+ TK_SHLIB_LD_EXTRAS="${TK_SHLIB_LD_EXTRAS}"' -install_name ${DYLIB_INSTALL_DIR}/${TK_LIB_FILE} -seg1addr 0xb000000 -unexported_symbols_list $$(f=$(TCL_STUB_LIB_FILE).E && nm -gjp $(TCL_BIN_DIR)/$(TCL_STUB_LIB_FILE) | grep ^_[[^_]] > $$f && echo $$f)'
fi
if test "$FRAMEWORK_BUILD" = "1" ; then