summaryrefslogtreecommitdiffstats
path: root/unix/configure.in
diff options
context:
space:
mode:
authordas <das>2007-02-04 02:51:57 (GMT)
committerdas <das>2007-02-04 02:51:57 (GMT)
commit4da034ee1780a1cf16e7296afd1ba9a84464457f (patch)
treedd99865f4b624ac2bb5b502d2644e8bf7ff88929 /unix/configure.in
parentaabe6cd039acad6c1f98ce17daa66437a97e7081 (diff)
downloadtk-4da034ee1780a1cf16e7296afd1ba9a84464457f.zip
tk-4da034ee1780a1cf16e7296afd1ba9a84464457f.tar.gz
tk-4da034ee1780a1cf16e7296afd1ba9a84464457f.tar.bz2
* unix/configure.in: add caching to -pipe check.
* unix/configure: autoconf-2.13
Diffstat (limited to 'unix/configure.in')
-rw-r--r--unix/configure.in21
1 files changed, 10 insertions, 11 deletions
diff --git a/unix/configure.in b/unix/configure.in
index d944f56..c1a6911 100644
--- a/unix/configure.in
+++ b/unix/configure.in
@@ -3,7 +3,7 @@ dnl This file is an input file used by the GNU "autoconf" program to
dnl generate the file "configure", which is run during Tk installation
dnl to configure the system for the local environment.
#
-# RCS: @(#) $Id: configure.in,v 1.83.2.36 2007/01/25 02:07:35 das Exp $
+# RCS: @(#) $Id: configure.in,v 1.83.2.37 2007/02/04 02:51:58 das Exp $
AC_INIT(../generic/tk.h)
AC_PREREQ(2.13)
@@ -88,16 +88,15 @@ AC_MSG_RESULT([$tk_ok])
# It makes compiling go faster. (This is only a performance feature.)
#------------------------------------------------------------------------
-if test -z "$no_pipe"; then
-if test -n "$GCC"; then
- AC_MSG_CHECKING([if the compiler understands -pipe])
- OLDCC="$CC"
- CC="$CC -pipe"
- AC_TRY_COMPILE(,,
- AC_MSG_RESULT([yes]),
- CC="$OLDCC"
- AC_MSG_RESULT([no]))
-fi
+if test -z "$no_pipe" && test -n "$GCC"; then
+ AC_CACHE_CHECK([if the compiler understands -pipe],
+ tcl_cv_cc_pipe, [
+ hold_cflags=$CFLAGS; CFLAGS="$CFLAGS -pipe"
+ AC_TRY_COMPILE(,, tcl_cv_cc_pipe=yes, tcl_cv_cc_pipe=no)
+ CFLAGS=$hold_cflags])
+ if test $tcl_cv_cc_pipe = yes; then
+ CFLAGS="$CFLAGS -pipe"
+ fi
fi
#------------------------------------------------------------------------