summaryrefslogtreecommitdiffstats
path: root/unix/configure.in
diff options
context:
space:
mode:
authordas <das>2007-02-04 02:51:47 (GMT)
committerdas <das>2007-02-04 02:51:47 (GMT)
commit9e82d733ad8686a5be07242f19d30fd459df5bd9 (patch)
treebe519e1bca00c1b4656352770ac97a0c25aaa048 /unix/configure.in
parent564a18890f8852cc78182cfec2cabfb6cb61b2e7 (diff)
downloadtk-9e82d733ad8686a5be07242f19d30fd459df5bd9.zip
tk-9e82d733ad8686a5be07242f19d30fd459df5bd9.tar.gz
tk-9e82d733ad8686a5be07242f19d30fd459df5bd9.tar.bz2
* unix/tcl.m4: use gcc4's __attribute__((__visibility__("hidden"))) if
available to define MODULE_SCOPE effective on all platforms. * unix/configure.in: add caching to -pipe check. * unix/configure: autoconf-2.59 * unix/tkConfig.h.in: autoheader-2.59
Diffstat (limited to 'unix/configure.in')
-rw-r--r--unix/configure.in21
1 files changed, 10 insertions, 11 deletions
diff --git a/unix/configure.in b/unix/configure.in
index 703a605..d7d308a 100644
--- a/unix/configure.in
+++ b/unix/configure.in
@@ -3,7 +3,7 @@ dnl This file is an input file used by the GNU "autoconf" program to
dnl generate the file "configure", which is run during Tk installation
dnl to configure the system for the local environment.
#
-# RCS: @(#) $Id: configure.in,v 1.130 2006/12/06 16:22:04 kennykb Exp $
+# RCS: @(#) $Id: configure.in,v 1.131 2007/02/04 02:51:48 das Exp $
AC_INIT([tk],[8.5])
AC_PREREQ(2.59)
@@ -103,16 +103,15 @@ fi
# It makes compiling go faster. (This is only a performance feature.)
#------------------------------------------------------------------------
-if test -z "$no_pipe"; then
-if test -n "$GCC"; then
- AC_MSG_CHECKING([if the compiler understands -pipe])
- OLDCC="$CC"
- CC="$CC -pipe"
- AC_TRY_COMPILE(,,
- AC_MSG_RESULT([yes]),
- CC="$OLDCC"
- AC_MSG_RESULT([no]))
-fi
+if test -z "$no_pipe" && test -n "$GCC"; then
+ AC_CACHE_CHECK([if the compiler understands -pipe],
+ tcl_cv_cc_pipe, [
+ hold_cflags=$CFLAGS; CFLAGS="$CFLAGS -pipe"
+ AC_TRY_COMPILE(,, tcl_cv_cc_pipe=yes, tcl_cv_cc_pipe=no)
+ CFLAGS=$hold_cflags])
+ if test $tcl_cv_cc_pipe = yes; then
+ CFLAGS="$CFLAGS -pipe"
+ fi
fi
#------------------------------------------------------------------------