summaryrefslogtreecommitdiffstats
path: root/unix/configure.in
diff options
context:
space:
mode:
authorKevin B Kenny <kennykb@acm.org>2006-11-08 15:39:28 (GMT)
committerKevin B Kenny <kennykb@acm.org>2006-11-08 15:39:28 (GMT)
commitba16786f04a14a4e1bb4e939ca9c17d4934931f1 (patch)
tree1fc720497a53533ddd67a25cfeebdcbcb342f022 /unix/configure.in
parent30f4adf499a0f678329b9e173152c951e2236e77 (diff)
downloadtk-ba16786f04a14a4e1bb4e939ca9c17d4934931f1.zip
tk-ba16786f04a14a4e1bb4e939ca9c17d4934931f1.tar.gz
tk-ba16786f04a14a4e1bb4e939ca9c17d4934931f1.tar.bz2
Silence warnings about Xft unless Xft is requested explicitly.
Diffstat (limited to 'unix/configure.in')
-rw-r--r--unix/configure.in30
1 files changed, 18 insertions, 12 deletions
diff --git a/unix/configure.in b/unix/configure.in
index 5d16b0b..3d741e4 100644
--- a/unix/configure.in
+++ b/unix/configure.in
@@ -3,7 +3,7 @@ dnl This file is an input file used by the GNU "autoconf" program to
dnl generate the file "configure", which is run during Tk installation
dnl to configure the system for the local environment.
#
-# RCS: @(#) $Id: configure.in,v 1.124 2006/11/08 15:19:51 dgp Exp $
+# RCS: @(#) $Id: configure.in,v 1.125 2006/11/08 15:39:29 kennykb Exp $
AC_INIT([tk],[8.5])
AC_PREREQ(2.59)
@@ -425,22 +425,28 @@ if test $tk_aqua = no; then
AC_ARG_ENABLE(xft,
AC_HELP_STRING([--enable-xft],
[use freetype/fontconfig/xft (default: on)]),
- [enable_xft=$enableval], [enable_xft="yes"])
+ [enable_xft=$enableval], [enable_xft="default"])
XFT_CFLAGS=""
XFT_LIBS=""
- if test "$enable_xft" = "yes" ; then
- XFT_CFLAGS=`xft-config --cflags 2>/dev/null` || enable_xft="no"
- XFT_LIBS=`xft-config --libs 2>/dev/null` || enable_xft="no"
- if test "$enable_xft" = "no" ; then
- enable_xft=yes
- XFT_CFLAGS=`pkg-config --cflags xft 2>/dev/null` || enable_xft="no"
- XFT_LIBS=`pkg-config --libs xft 2>/dev/null` || enable_xft="no"
+ if test "$enable_xft" == "no" ; then
+ AC_MSG_RESULT([$enable_xft])
+ else
+ found_xft="yes"
+ XFT_CFLAGS=`xft-config --cflags 2>/dev/null` || found_xft="no"
+ XFT_LIBS=`xft-config --libs 2>/dev/null` || found_xft="no"
+ if test "$found_xft" = "no" ; then
+ found_xft=yes
+ XFT_CFLAGS=`pkg-config --cflags xft 2>/dev/null` || found_xft="no"
+ XFT_LIBS=`pkg-config --libs xft 2>/dev/null` || found_xft="no"
fi
- if test "$enable_xft" = "no" ; then
- AC_MSG_WARN([Can't find xft configuration])
+ AC_MSG_RESULT([$found_xft])
+ if test "$found_xft" = "no" ; then
+ if test "$enable_xft" = "yes" ; then
+ AC_MSG_WARN([Can't find xft configuration])
+ fi
+ enable_xft=no
fi
fi
- AC_MSG_RESULT([$enable_xft])
if test $enable_xft = "yes" ; then
UNIX_FONT_OBJS=tkUnixRFont.o
AC_DEFINE(HAVE_XFT, 1, [Have we turned on XFT (antialiased fonts)?])