summaryrefslogtreecommitdiffstats
path: root/unix/configure.in
diff options
context:
space:
mode:
authordkf <donal.k.fellows@manchester.ac.uk>2010-03-23 10:45:13 (GMT)
committerdkf <donal.k.fellows@manchester.ac.uk>2010-03-23 10:45:13 (GMT)
commit896f5c16bc45c33a1010c373664a806455cdce47 (patch)
tree32f5e2fa78a58a4922a2757b6d70b79868f6a858 /unix/configure.in
parentb76131c53da56bee1254947caed81e4107ac9f00 (diff)
downloadtk-896f5c16bc45c33a1010c373664a806455cdce47.zip
tk-896f5c16bc45c33a1010c373664a806455cdce47.tar.gz
tk-896f5c16bc45c33a1010c373664a806455cdce47.tar.bz2
* unix/configure.in, unix/Makefile.in: [Bug 2965133]: Get rid of the
spurious NONE and some pointless quotes that were causing problems with building Tk on OSX. Overall bug might not yet be solved.
Diffstat (limited to 'unix/configure.in')
-rw-r--r--unix/configure.in4
1 files changed, 3 insertions, 1 deletions
diff --git a/unix/configure.in b/unix/configure.in
index 6f49152..8187c92 100644
--- a/unix/configure.in
+++ b/unix/configure.in
@@ -3,7 +3,7 @@ dnl This file is an input file used by the GNU "autoconf" program to
dnl generate the file "configure", which is run during Tk installation
dnl to configure the system for the local environment.
#
-# RCS: @(#) $Id: configure.in,v 1.170 2010/02/22 23:38:53 nijtmans Exp $
+# RCS: @(#) $Id: configure.in,v 1.171 2010/03/23 10:45:13 dkf Exp $
AC_INIT([tk],[8.6])
AC_PREREQ(2.59)
@@ -418,7 +418,9 @@ fi
#--------------------------------------------------------------------
if test "x${x_libraries}" != "x"; then
+ if test "x${x_libraries}" != "xNONE"; then
LIB_RUNTIME_DIR="${LIB_RUNTIME_DIR}:${x_libraries}"
+ fi
fi
if test "${TCL_LD_SEARCH_FLAGS}" = '-L${LIB_RUNTIME_DIR}'; then
LIB_RUNTIME_DIR=`echo ${LIB_RUNTIME_DIR} |sed -e 's/:/ -L/g'`