summaryrefslogtreecommitdiffstats
path: root/unix/tk.spec
diff options
context:
space:
mode:
authorericm <ericm>2000-02-14 22:43:32 (GMT)
committerericm <ericm>2000-02-14 22:43:32 (GMT)
commit3bd63647333cb70952f3565159c81c7e50d69fa8 (patch)
tree7bb92986616b9bff96cf1e44b657907e05aba426 /unix/tk.spec
parent3539ffc10ed8dfe6d3cc40b16493e82511545759 (diff)
downloadtk-3bd63647333cb70952f3565159c81c7e50d69fa8.zip
tk-3bd63647333cb70952f3565159c81c7e50d69fa8.tar.gz
tk-3bd63647333cb70952f3565159c81c7e50d69fa8.tar.bz2
* unix/tk.spec: RPM specification for producing a binary Tk RPM for Linux.
* unix/Makefile.in: Added rpm target to generate Tk binary RPM.
Diffstat (limited to 'unix/tk.spec')
-rw-r--r--unix/tk.spec52
1 files changed, 52 insertions, 0 deletions
diff --git a/unix/tk.spec b/unix/tk.spec
new file mode 100644
index 0000000..a69a68d
--- /dev/null
+++ b/unix/tk.spec
@@ -0,0 +1,52 @@
+# $Id: tk.spec,v 1.1 2000/02/14 22:43:32 ericm Exp $
+# This file is the basis for a binary Tk Linux RPM.
+
+%define version 8.3.0
+%define directory /usr/local
+
+Summary: Tk graphical toolkit for the Tcl scripting language.
+Name: tk
+Version: %{version}
+Release: 1
+Copyright: BSD
+Group: Development/Languages
+Source: ftp://ftp.scriptics.com/pub/tcl/tcl8_3/tk%{version}.tar.gz
+URL: http://www.scriptics.com/
+Packager: Scriptics Corporation
+Buildroot: /var/tmp/%{name}%{version}
+Requires: XFree86-libs >= 3.3.3, XFree86-devel >= 3.3.3, tcl = 8.3.0
+
+%description
+The Tcl (Tool Command Language) provides a powerful platform for
+creating integration applications that tie together diverse
+applications, protocols, devices, and frameworks. When paired with
+the Tk toolkit, Tcl provides the fastest and most powerful way to
+create GUI applications that run on PCs, Unix, and the Macintosh. Tcl
+can also be used for a variety of web-related tasks and for creating
+powerful command languages for applications.
+
+%prep
+
+%build
+./configure --prefix %{directory} --exec-prefix %{directory}
+make CFLAGS=$RPM_OPT_FLAGS
+
+%install
+rm -rf $RPM_BUILD_ROOT
+make INSTALL_ROOT=$RPM_BUILD_ROOT install
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+# to create the tcl files list, comment out tk in the install section above,
+# then run "rpm -bi" then do a find from the build root directory,
+# and remove the files in specific directories which suffice by themselves,
+# then to create the files list for tk, uncomment tk, comment out tcl,
+# then rm -rf $RPM_BUILD_ROOT then rpm --short-circuit -bi then redo a find,
+# and remove the files in specific directories which suffice by themselves.
+%files -n tk
+%defattr(-,root,root)
+%{directory}/lib
+%{directory}/bin
+%{directory}/include
+%{directory}/man